STM32 MCUs products

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! STM32L433 VREFINT_CAL Value

Hello,I'm trying to work with the ADC of the STM32L433 microcontroller. The Reference manual (RM0394) on page 448 it says : The following formula gives the actual VDDA voltage supplying the device:VDDA = 3.0 V x VREFINT_CAL / VREFINT_DATAWhere can I ...

RStra by Associate III
  • 263 Views
  • 2 replies
  • 0 kudos

Resolved! STM32L412K8 Exposed Pad question

Hi!I'm an EE designing a PCB. Referencing the datasheet: https://www.st.com/resource/en/datasheet/stm32l412k8.pdfSection 7.4 on page 178, UFQFPN48, the Exposed Pad (EP) says that it should be connected to GND.Section 7.6 on page 184, UFQFPN32 (the ch...

EngPete by Associate
  • 98 Views
  • 3 replies
  • 3 kudos

DCMI OV5640 STM32L4A6

Hi Community!My goal is to capture an bmp image with the resolution of 640x480. But to check first if the camera is correct connected and works perfectly, I'm trying to take a JPEG image.I've successfully connected my Nucleo-L4A6ZG with an Adafruit d...

nicola3 by Associate II
  • 72 Views
  • 0 replies
  • 0 kudos

Resolved! printf causes terminal to stay just empty.

Hey. I tried to setup `printf` using the following forum post. I am using the `NUCLEO-L4A6ZG`.Here what I've tried so far. I connected the `USART2` to the Pins `PA2` (RX) and `PA3` (TX):(By default LPUART1 was configured and connected to PG7/8, since...

usart2.png putty-settings.png putty.png
stmax by Associate II
  • 275 Views
  • 18 replies
  • 12 kudos

about Execute in place using dual quad spi

What I want to do is XIP with DUAL QUAD SPI.The environment is as follows.Use Board : nucleo l4r5ziIDE : Atollic TrueSTUDIO® for STM32, Built on Eclipse Neon.1a.(Version: 9.3.0)FLASH : W25Q64JVThe connection diagram of the board and FLASH is shown be...

Myasu1_0-1708448593094.png Myasu1_0-1708697574834.png Myasu1_1-1708698042431.png Myasu1_2-1708698571213.png
Myasu.1 by Senior
  • 199 Views
  • 9 replies
  • 1 kudos

EEProm library clean time

I was reading the documentation from: https://www.st.com/en/embedded-software/x-cube-eeprom.html#documentationabout the eeprom lib. Concerning the cleanup time, I don't follow where the number comes from. I am using an L4 and there was only one examp...

dsauter_0-1708650884906.png
dsauter by Associate
  • 83 Views
  • 4 replies
  • 1 kudos

STM32L476

Dear Sir,I use NUCLEO-L476 , Once I connect it to usba new window pop up like with the Caption NODE_L476RG .Erasing the CPU still the window pop up.What should I do to make this board to act as plain PCB  

Jump to System bootloader: does not stay inside

It has been asked several times, however I can not find a working solution for me.With STM32L486RGT6 I achieved to implement jump to bootloader, entering DFU mode successfully. All fine!Doing it similar for STM32L071CZY6TR and STM32F469VE it does not...

Led by Senior
  • 146 Views
  • 11 replies
  • 1 kudos