STM32 MCUs products

Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Hi All STM32 users, has anyone successfully done any debugging using VSCode with all the relevant packages installed along with the ST-LINK/V2 probe on Linux?

I have all the relevant ARM utils/etc on the system.As soon as I try to run, I get this message-"Could not start GDB process, does the program exist in filesystem?"Tried jumping through hoops for last few days but getting no where.Tried with all kind...

WTAYL.1 by Associate
  • 3 replies
  • 0 kudos

Problems using ST-GDB Server on Linux Mint

I have the newest Version of ST/Atollic TrueStudio installed on my Linux Mint Machine. Operating System: Linux Mint 19 Kernel: Linux 4.15.0-20-generic Architecture: x86-64When Itry to upload my Code I get the following error:STMicr...

PWass by Associate
  • 1 replies
  • 0 kudos

OpenOCD support for external STLink debugger

Posted on November 05, 2017 at 07:41Hi all,Is anyone using OpenOCD with genuine external STLinkV2 debugger/programmer and STM32L0? Clearly, there is an issue as I have tested multiple units and OpenOCD releases (0.9, 0.10.).The debuggers are fully f...