STM32 MCUs products

Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! SDMMC does not work after power cycle

Hi,I am using STM32H747. I have successfully write&read micro sd card over SDMMC2 peripheral while debugging. But after debugging, when I power cycle or reset the board, I am not able to use sd card. I see FatFS open file failing. The board is arduin...

serhat1 by Associate
  • 1 replies
  • 0 kudos

SDIO 4 bit mode with STM32CubeMX

I would like to use SDIO with 4 bit mode with FatFS. I use STM32F429I Discovery board and I wired a micro SD card board to it. The SD card is a 16 GB SanDisk Ultra A1 card formatted to FAT32.This is the micro SD card board:

djhtml by Associate II
  • 21 replies
  • 1 kudos

Resolved! SD Write error some time , not stable

Hi ,   I made a STM32F405VGT6 board with SD card interface. The SD code is generated using STM32CUBEMX and FatFs middleware.   The SD file write is not stable, it return error sometimes after calling f_write(). However, if I run the same code in uVis...

MHo.15 by Associate III
  • 5 replies
  • 0 kudos

Uboot failed when "Saving Environment to MMC..."

Hi,we have an image, install on few SD cards. Most of them boots just fine, but few of them get stuck at  "Saving Environment to MMC...".I tried to reduce the SD clock to 25, 12.5MHz but it doesn't help. Does anyone know where the point to investigat...

eMMC stop and restart

hi all,we have an application that requires powering an eMMC down and then back up while the MCU keeps running. BackgroundWe're successfully using the eMMC connected to the SDMMC1 peripheral running on a 25MHz 8-bit bus, with ClockPowerSave ENABLED. ...

DShar.17 by Associate II
  • 3 replies
  • 0 kudos

Resolved! STM32H747AI

Hello,I am relatively new here and would like to try to design a STM32H747AI board with LiPo battery power supply for wearable devices with features like OLED microdisplay, WiFi+Bluetooth and GNSS module. Since I would like to run a GUI on it with sm...

FR_NOT_READY with SDIO, microSD 32GB and MCU STM32F407

I was trying to interface a microSD card (32GB) with STM32F407 through SDIO. Tried 1-bit and 4-bit modes. But it always gets me back FR_NOT_READY. and the program always stuck here: FATFS configuration: SDIO configuration: Clock:Where I'm doing any m...

MKDas_0-1691048899635.png MKDas_1-1691048968290.png MKDas_2-1691049050508.png MKDas_3-1691049071703.png
MKDas by Associate II
  • 0 replies
  • 0 kudos