STM32 MCUs products

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Could not halt device (19)

Hi,I am trying to program STM32F030C8T6 with STM32CubeIDE. When I try to upload the code, it says the download was successful but then it fails to halt the device. I have tried setting "Reset behaviour" to "None" as other posts have suggested, but th...

JS8 by Associate III
  • 748 Views
  • 9 replies
  • 0 kudos

USB Virtual Com to send/receive message

I have enabled USB Device FS and successfully use it as a virtual com port.I now need to determine the best way to send messages from master to slave over this port, and how I will handle potentially corrupted data, timeouts, and how enabling CRC wil...

LMorr.3 by Senior II
  • 551 Views
  • 6 replies
  • 2 kudos

Resolved! NUCLEO-F756ZG SPI1 issue

Dear ST,I try to use SPI1 in full-duplex slave mode with hardware NSS and interrupts.Interrupts work fine, the only problem is that data is all 0After connecting the logic analyzer I noticed that the CS and SCK signals are ok but the MOSI and MISO ar...

AHape.1 by Associate II
  • 556 Views
  • 7 replies
  • 3 kudos

Resolved! I2S and DMA HAL problem (DMA trigger only once) STM32H7

Hello,I'm trying to use the I2S transceiver on a STM32H7.I did a first simple experiment using the HAL function: HAL_I2S_Receive_DMAI use a basic loop in the main:while (1){  if (i2s_bsy == 0) {    i2s_bsy = 1;    i2s_status = HAL_I2S_Receive_DMA(&hi...

mkhairy by Associate II
  • 364 Views
  • 3 replies
  • 0 kudos

Resolved! not able to read WHO_AM_i Register value.

i am using IMU ICM-42688-P sensor communicating with stm32 GOB1CET6N board using spi protocol. but, i am not able to read WHO_AM_I Value for more than 2MHz frequency. i have tried all settings but nothing is working. datasheet of sensor says SPI work...

Rohit007 by Associate II
  • 330 Views
  • 2 replies
  • 1 kudos