STM32CubeMX (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

The CubeMX/CubeIDE login issue is resolved

Hello CubeMX/CubeIDE users.  From the time period of May 14 to May 17, 2024, some users have faced issues when connecting to the ST network while using CubeMX or CubeIDE.Some examples were issues downloading firmware packages using STM32CubeMX and ST...

STM32CubeMX 6.11.1 released

STM32CubeMX 6.11.1 was released on st.com as well as an in-tool update patch. Main issues fixed in this patch: Ticket 176645 : STM32CubeMX V6.11.0 has lost the "JTAG (5 pins)" debug mode for all the STM32H7 series but the STM32H7Rx/7Sx microcontrolle...

STM32CubeMX 6.11.0 released

We are pleased to announce you that the official release of STM32CubeMX V6.11.0 is available. What is new in STM32CubeMX V6.11.0? New MCUs series : STM32U0 (STM32U083xx/73xx/31xx), STM32H7RS (STM32H7R7xx/H7R3xx/H7S3xx/H7S7xx) and STM32H5 (STM32H533/H...

Resolved! I cant seem to make a pwm work.

I have a project where I want to add a simple PWM. I'm using the stm32h series. I have a scope on PA3, and I set up my timer2 for PWM on channel 4. I did this all in the IOC file as I want to understand how to create the PWM I need. I see it added my...

ulao by Associate III
  • 633 Views
  • 7 replies
  • 1 kudos

STM32F769I EVAL CAN problems

Hello,we are trying to listen to can messages with our evaluation board. We are using a PCAN-USB adapter to play a can log to our eval board.When starting the PC program it says that there is no can buffer detected. We assume that somehow our CAN Tra...

0693W00000YAt9sQAD.png
LDini.1 by Associate II
  • 405 Views
  • 3 replies
  • 1 kudos

Unable to TX on NUCLEO-ST32G491RE FDCAN1

I am trying to get CAN working on the STM32G491RE. I happily worked with CAN on STM32F4xxx micros, but the landscape seems to have changed on the STM32G491RE.The presented code is from a minimal project for the NUCLEO-STM32G491RE board. It is in defa...

JBend.6 by Associate III
  • 288 Views
  • 0 replies
  • 0 kudos

SO8N STM32G031C6 USART not working.

I'm trying to setup an USART for a very small MCU of the STM32G0 family, the MCU it's theoretically being programmed, but the USART is not responding, I configured the MCU just like I did in other projects (of bigger MCUs), I'm not able to find what ...

0693W00000YAa9tQAD.png 0693W00000YAaAhQAL.png
fancyrat by Associate III
  • 1211 Views
  • 18 replies
  • 1 kudos

Resolved! STM32CubeMX 6.7.0 does not configure SDMMC DMA correctly

I am having an issue similar to https://community.st.com/s/question/0D53W000027iXpbSAE/spi-dma-configuration-generated-by-stm32cubemx-does-not-work but with the SDMMC peripheral rather than SPI.I have an STM32CubeMX project targeting the 32F746GDISCO...

FPlow.1 by Associate II
  • 465 Views
  • 2 replies
  • 0 kudos