STM32CubeMX (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! NUCLEO-H563ZI SPI Master example is not working

Hi I'm trying to run SPI_FullDuplex_ComIT_Master and Slave examples that use SPI1 on NUCLEO-H563ZI boards.The pin connections in the read me seems to be inaccurate i.e1. There is no PA5 on 10th pin of CN6 on the Nucleo but it is there on CN7.2. There...

WCarey_0-1712129354068.png
WCarey by Associate II
  • 148 Views
  • 4 replies
  • 0 kudos

Resolved! Problem with FreeRtos

Hi We are using product STM32H56 series , I am encountering problem while building my project .I am STM32cubeIDE , trust zone enabled .I enabled X-CUBE-FREERTOS  M33non secureIn software package I installed   -STm X-CUBE-FREERTOS  -CMSIS RTOS2-TZ_non...

Kendall7_0-1711443563549.png
Kendall7 by Associate II
  • 157 Views
  • 1 replies
  • 0 kudos

Resolved! STM32CubeMX bug for FDCAN?

Hi STI am using STM32CubeMX v6.10.0 with selected MCU STM32H563ZITx.When configuring FDCAN1 I may have found a bug in the tool. The below two Nominal Time Seg1 and Seg2 say that the lowest value is "2" and the tool is limiting setting it to "1" which...

Imre_0-1707302997348.png Imre_1-1707303014423.png Imre_2-1707303308710.png
Imre by Associate II
  • 326 Views
  • 3 replies
  • 1 kudos

Resolved! STM32CubeMX 6.10.0 doesn't copy all necessary I3C headers

Reproduction steps:Open STM32CubeIDE. “File” menu → “New” → “STM32 Project”.Switch to the “Board Selector”, and pick the NUCLEO-H503RB. Click “Next”.I've successfully reproduced this issue with the NUCLEO-H503RB and NUCLEO-H563ZI. I suspect it applie...

Resolved! Ethernet peripheral missing from STM32H5 in CubeMX

The Ethernet peripheral is missing from the STM32H5 in STM32CubeMX 6.10!It appears if the Nucleo or Discovery kit boards are selected as the starting point for a project, but if the project is started from a device selection the Ethernet peripheral i...

GaryA by Associate II
  • 429 Views
  • 4 replies
  • 0 kudos

Resolved! STM32H5 CubeMX HMI BSP Related Bug

It seems STM32CubeMX has a bug related to the STM32H5's HMI BSP component. If you do not wish to use this BSP component and want to configure the affected pins manually (like with other boards that do not have this HMI BSP component), the project wil...

USB_DEVICE missing from CubeMX

CubeMX version 6.10.0Chip is STM32H563IIKxFirmware package is STM32Cube FW_H5 v1.1.1 (which is the latest shown in the software packages manager).Neither USB_DEVICE nor USB_HOST is listed in middlewares:As can be seen, my project involves FreeRTOS wh...

BrianH_0-1706126637661.png
Brian H by Associate III
  • 305 Views
  • 2 replies
  • 0 kudos

NETXDUO lan8742 added twice to Makefile

Dear community,we're using a Makefile Project with STM32H5xx and NetX Duo using the LAN8742When the code is generated, CubeMX is adding the line:.../STM32Cube/Repository/STM32Cube_FW_H5_V1.1.1/Drivers/BSP/Components/lan8742/lan8742.c \twice to the Ma...

stst9180 by Associate III
  • 644 Views
  • 5 replies
  • 0 kudos