STM32CubeMX (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! HardFault after EXTI and starting & resetting timer SOLVED

HiI get a hardfault as soon as the HALL sensor (which is connected & set up using CubeMX & EXTI GPI(O)) gets an interrupt.I have debugged the code to the part where I can safely say that the hard fault only occurs when the " __HAL_TIM_SET_COUNTER(&ht...

Lixx by Associate III
  • 663 Views
  • 7 replies
  • 0 kudos

Resolved! Debugging the microcontroller

I'm just starting to learn microcontrollers, so I have a question.I have STM32F103C8T6 and STLINK V2 programmer.Connected lines SWDIO, SWCLK, SWO(PB3) and RESET In CUBE MX I choose "No Debug" or "Serial Wire" or "Trace Asynchrone SW" and in CUBE IDE ...

0693W00000bhUkrQAE.jpg 0693W00000bhUjAQAU.jpg 0693W00000bhUj0QAE.jpg 0693W00000bhUhdQAE.jpg
DMukh.2 by Associate II
  • 341 Views
  • 1 replies
  • 0 kudos

Resolved! SWD Conflict w/ USART2 or System Wake-Up on STM32L0?

Using CubeMX to create a new project on the STM32L0X0 series. I need two UARTS, which this part offers. However, in CubeMX, when I try to enable the SWD, it creates a conflict is the SYS tab for "System Wake-Up 3". When I roll over this, it says it c...

jvavra by Associate III
  • 319 Views
  • 1 replies
  • 0 kudos

STM32F411 JTAG setting bug

Hello,I use CubeMx (6.6.1), STM32F411CCUx​​CubeMx causes a problem when 'PB4' pin and JTAG (4 pin) are used together.​​​If JTAG (4pin) is set in CubeMx, PB4 is not used.If i set something in PB4, JTAG is released.​​ In the datasheet, PB4 and debug ha...

0693W00000QLbb6QAD.png 0693W00000QLbb0QAD.png
hjuns by Associate III
  • 328 Views
  • 4 replies
  • 0 kudos

Resolved! STM32CubeMX V6.6.1 HAL driver crashes, LL interface works

This is my first STM32 project and I am using an STM32F030C6T as a MODBUS slave device. I used the STM32CubeMX V6.6.1 to create a project template and STM32CubeIDE Version: 1.10.1 Build: 12716_20220707_0928 (UTC), along with an STlink interface.When ...

0693W00000VOIHgQAP.png 0693W00000VOIIjQAP.png
RMurt.3 by Associate III
  • 769 Views
  • 9 replies
  • 0 kudos

Resolved! STM32F733 startup with a CubeMX project

I'm bringing up a new project using STM32F733, with code generated from CubeMX version 6.6.1, with difficulty. Looking for suggestions.1) When I change the HAL timebase source from the default SysTick to something else, I've tried TIM2 and TIM10, the...

GHolc.1 by Associate III
  • 401 Views
  • 3 replies
  • 0 kudos