STM32CubeMX (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! STM32CubeIDE 1.15 Bug (switching from SysTick to TIM16)

I'm using the Nucleo-C031C6 board, and I chose this (NUCLEO-C031C6) from the board selector when starting the IDE. (STM32CubeIDE v1.15). I tried switching Timebase Source (in SYS menu) from SysTick to TIM16, then when I compiled, I got this error:../...

JLoh by Associate
  • 549 Views
  • 2 replies
  • 1 kudos

Problem with IDE

Hello, I've got problem with STMCubeIDE. You can see my problem at photos I attached. Can anyone help me to solve this problem. I try to work on Lenovo Legion 5 with Ryzen 5 5600h and RTX3060. Second graphic card is integrated with Ryzen CPU. This pr...

Related to STM32C0 board

I have connected STM32C031C6T6 board to my device but it has not been detected for some reason, it was working fine before but not working now, I have reset it as well still no use, kindly tell me what to do. 

qw1 by Associate
  • 260 Views
  • 1 replies
  • 0 kudos

NUCLEO-C031C6: Error when updating via MX

Good day,There seems to be an error in the implementation of the NUCLEO-C031C6 when generating code for the project after updating the peripherals. After loading an example project and compiling and testing all is well but once you update the project...

CKlib by Associate II
  • 716 Views
  • 7 replies
  • 0 kudos

How do I get the USART to work on an STM32C011?

I am relatively new to using the STM32 family and I am trying to use the USART on a STM32C011J4M6 device without success.Initially I am just trying to send out a single character using the lines uint8_t TxData[] = {'@'}; HAL_UART_Transmit(&huart...

Neiliow by Associate II
  • 830 Views
  • 7 replies
  • 0 kudos

Resolved! Problem with STM32C031K6 and ADC DMA

Hello,I am testing a STM32C0 MCU to see if it might be good for a project I'm working on attracted by the price point, but I have to say that I have some unexpected problem.Among several the most relevant is multichannel DMA based ADC conversion that...

0693W00000aHEa2QAG.png 0693W00000aHEl4QAG.png 0693W00000aHEYbQAO.png 0693W00000aHElsQAG.png
FCamp.1 by Associate III
  • 853 Views
  • 9 replies
  • 0 kudos

Resolved! CubeMX 6.6.1 + STM32C0 package 1.0.0 incorrect config

When creating project using Board Selector, Nucleo-C031C6, the incorrect MCU pinout definition is created with two errors: I2C1 is activated and pins are assigned for it and USART1 is initialized using PB6&PB7 instead of USART2 with pins PA2&PA3,whic...

gbm by Lead II
  • 482 Views
  • 3 replies
  • 0 kudos