STM32CubeMX (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

STM32U5 IAP_main example NOT working

Hi,I am using STM32CubeMX version 6.11.0 .I want to test the "IAP_main" example for the STM32U575I-EV.I start the project as follows : Then when I try to Generate Code for the STM32CubeIDE in CubeMX the following error occurs: The code gets generated...

IAP_main_u5_error0.png IAP_main_u5_error1.png IAP_main_u5_error2.png

No Activity at all on SDIO Lines

Hi Everyone,I have been trying to get SDIO working (4-bit) using STM32CubeMX and a NUCLEO-F401RE dev board. I am using the Adafruit SDIO breakout board here: Adafruit Micro SD SPI or SDIO Card Breakout Board . Unfortunately, no matter what I change i...

LogicOutput.png Warwick_0-1710528251261.png
Warwick by Associate
  • 130 Views
  • 2 replies
  • 0 kudos

Resolved! Is there a bug in STM32CubeMX about SDIOCLK?

STM32f103vet6It's in the manual that SDIO adapter clock (SDIOCLK = HCLK).  When HCLK is set to 72MHz, SDIO_CK is configured through the register SDIO_CLKCR bit 7:0(CLKDIV). When the bypass clock is not used, SDIO_CK=SDIOCLK/[CLKDIV+2], which should b...

XvSenfeng_3-1704782951218.png XvSenfeng_4-1704782976160.png XvSenfeng_6-1704783374909.png XvSenfeng_5-1704783155276.png

SDCARD does not work with 4bits wide bus

Hi I have STM32F407 and after updating STM32CubeMX 6.6.1 -> 6.9.2 I faced the same issue with SD card:https://community.st.com/t5/stm32cubemx-mcus/sdcard-does-not-work-fr-not-ready-when-migrating-from-fw-f4-v1/m-p/115499#M3876It seems that with previ...

JBond.1 by Senior
  • 1443 Views
  • 8 replies
  • 2 kudos

problems with STM32F405 SD Card 4wiresCubeMX

hello,i work in STM32F405, create projet with cubeMx, SD 4 wires.Pull up in the schematic D0..3 , CMD, no internal pull in cube MXmount return FR_NOT_READYwhen SD_WideBus_Enable() (in hal_sd) call:in SD_FindSCR() after the cmd 51 , there is a polling...

trave.1 by Associate II
  • 670 Views
  • 3 replies
  • 2 kudos

Resolved! How to make SDIO & eMMC FatFs Work with STM32F4 ?

HelloI am using :STM32F413HDESCOVRYSTM32 CubeMX toolAtollic TrueStudio V9.3eMMC : Kingston EMMC04GI already created the files user_discio.c user_discio.h eMMC_Driver.ceMMC_Driver.hwhen i use f_mount i get FR_NO_FILESYSTEMthx

0690X0000089iuXQAQ.jpg
Mcherif by Associate II
  • 1321 Views
  • 8 replies
  • 0 kudos