STM32CubeMX (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

STM32CubeMX 6.11.0 released

We are pleased to announce you that the official release of STM32CubeMX V6.11.0 is available. What is new in STM32CubeMX V6.11.0? New MCUs series : STM32U0 (STM32U083xx/73xx/31xx), STM32H7RS (STM32H7R7xx/H7R3xx/H7S3xx/H7S7xx) and STM32H5 (STM32H533/H...

LwIP TFTP on STM boards

I was struggling to get LwIP TFTP server working on MCU boards (NUCELO-H743ZI). After debugging I have found:Why is TFTP_MAX_MODE_LEN defined as 7 (instead of >= 8)?Why is TFTP_MAX_FILENAME_LEN just defined as 20?So, it results in:sending (PUT) or re...

When I installed STM32CubeIDE 1.10.1 on my laptop (connected to internet), I can open the Embedded Software Packages Manager and under STM32F4, the option to install version 1.27.1 appears.

When I repeat the above procedure on my offline desktop, I do not get the option to install 1.27.1, as 1.27.0 is the newest option that appears. I routinely install patches offline, but this is the first time I have encountered this issue. Any ideas?

RFrac by Associate
  • 139 Views
  • 0 replies
  • 0 kudos

Resolved! STM32F7 DACs enabling inconsistently upon powerup

Using STM32F765VG6TR, every time I power on the MCU, the two DACs are supposed to be set to constant output voltages of 2.4V and 0.8V. This happens inconsistently - sometimes it works, about 50/50 success rate. A few notes:If it isn't working, an MCU...

0693W00000QKcDbQAL.png 0693W00000QKcDWQA1.png 0693W00000QKcANQA1.png
Auhv by Associate II
  • 697 Views
  • 7 replies
  • 0 kudos

STM32CubeMX 6.6.1 released

Fixed issue131250 source files got deleted after project migration Related threadsSTM32CubeIDE 1.10.0 Migration IssueHow to avoid project migration issue in STM32CubeMX v6.6.0 and STM32CubeIDE v 1.10.0

Resolved! Problem with new version STM32CubeIDE ver1.5.1 and STM32CubeMX ver6.1.1 (fatal error: usb_device.h: No such file or directory)

Before that there was STM32CubeIDE ver1.4.0 STM32CubeMX ver6.0.0 everything was fine.Installed STM32CubeIDE ver1.5.1 and STM32CubeMX ver6.1.1, there was an error when connecting USB_DEVICE.Tried creating a project from scratch with nothing but USB_DE...

0693W000007BX7KQAW.png
ADysh.1 by Associate II
  • 1811 Views
  • 10 replies
  • 1 kudos

Resolved! STM32CubeIDE 1.10.0 Migration Issue

Hi, I am experiencing issues migrating projects from STM32CubeIDE 1.9.0 to 1.10.0. After performing the migration, a number of custom project .c/.h files are deleted from the project and filesystem, and some are completely replaced, deleting /*USER ...