STM32 MCUs Wireless

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! Zigbee: ip802154_lld_exitSleep() FAILED

Hello, testing Zigbee_OnOff_Client_SED on P-NUCLEO-WB55. Sources are from version 1.18.0, same as installed stm32wb5x_Zigbee_FFD_fw.bin. Almost no changes to source files except modification channelmask to WPAN_CHANNELMASK_2400MHZ.After a while (rand...

SToma by Associate III
  • 382 Views
  • 7 replies
  • 1 kudos

BLE_p2pClient example does not work

Hi, I am using two NUCLEO WB15CC boards to make the BLE p2pcentral and BLE p2pServer work as said in the ReadMe of the these examples. But I always run into the same error on the client side. I am using the latest firmware on both sides. From the deb...

ElijahM_0-1703592935382.png ElijahM_1-1703593090507.png
ElijahM by Associate
  • 149 Views
  • 0 replies
  • 0 kudos

Resolved! Error with SigFox credentials again.

Hello, This has happened before (here) and was fixed, but it seems that it is happening again.When the downloaded .zip file is opened with a text editor, the contents is:"Service unavailable, please try again later"Please can someone take a look at t...

tomzo by Associate II
  • 357 Views
  • 3 replies
  • 3 kudos

STM32WL55 FreeRTOS and SubGHz_Phy

Hello everyone,We are a group of students working on the development of flight control and communication software as part of a space program. Our project is based on the STM32Wl55 MCU with LoRa and FreeRTOS. Currently, we are transitioning our softwa...

Bildschirmfoto 2023-10-24 um 16.23.08.png

wM-BUS Demo Suite + L152RE - S2868A2 problems

Hello,I bought a  L152RE coupled to a S2868A2 in order to try to sniff data coming from a water meter I own.I tried to use S2LP-CONC-PC-GUI contained in x-cube-subg1 with the wM-BUS Demo Suite.I can successfully flash the code in my board then I pres...

wM-Bus_Demo_Suite_uQgHc1ceNI.png wM-Bus_Demo_Suite_KoYxy6Bon4.png stm32cubeide_X2YRTBgp6T.png
Rihen by Associate
  • 182 Views
  • 0 replies
  • 0 kudos

Resolved! Linker script not placing MB_MEM2 in SRAM2

I'm using a NUCLEO-WB55RG board and if I create a new project in STM32CubeIDE 1.12.0 and enable the STM32_WPAN and HeartRate example it doesn't work because the different buffers that need to be in SRAM2 is not placed there.The app_entry.c defines th...

EBotö.1 by Associate II
  • 468 Views
  • 4 replies
  • 0 kudos