STM32 MCUs Wireless

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! STM32WL55 dual core debug _ error 18 when debugging CM0+

Hello,I have started to use stm32wl55 nucleo.I try to debug a basic application.I start by debugging CPU1 (CM4) than after booting CPU2 (CM0+) i run the debug for the second CPU.But ST-LINK: Could not verify ST device!error details :Error in final la...

malarab by Senior
  • 4252 Views
  • 14 replies
  • 0 kudos

Problem with trace utility in I-CUBE-LRWAN

Hello,I'm currently working on an application that integrates the LoRaWAN stack (version 2.1.0), and has to use USART2 to send/receive data. USART2 is already used by the trace utility, to send trace messages. I activated RX on interruption by callin...

Hard fault in X_CUBE_CRYPTOLIB, how to proceed?

Our STM32WB55 user application is currently in the HardFault_Handler. (Full disclosure: I am not an embedded developer at all, I have never debugged such a problem, so I'm not really knowing what I am doing. I need precise, detailed step-by-step inst...

_legacyfs_online_stmicro_images_0693W00000dK209QAC.png _legacyfs_online_stmicro_images_0693W00000dK1RyQAK.png _legacyfs_online_stmicro_images_0693W00000dK23IQAS.png
LWChris by Associate III
  • 250 Views
  • 0 replies
  • 0 kudos

HardFault Interrupt when trying to erase flash?

Hello...I am using a Nucleo WB55 board. I can run the FLASH_EraseProgram that comes with the WB55 example code successfully. I have pre-existing code and am trying to pull this into my code. I have checked the PWR and the Flash SFR in the debugger...

SWenn.1 by Senior III
  • 273 Views
  • 2 replies
  • 0 kudos

zigbee issue on NUCLEO-WB55

Hi, I'm trying to start the zigbee on Nucleo-WB55.After upgrading the FUS to 1.2.0.0 and Stack to 1.16.0.0 without any problem, I get an issue in the running code when it checks the "StackType",it should be 48 or 49 but it returns 0:Tested with two ...

_legacyfs_online_stmicro_images_0693W00000bhwkGQAQ.png _legacyfs_online_stmicro_images_0693W00000bhwlEQAQ.png
PCu1 by Senior
  • 400 Views
  • 3 replies
  • 1 kudos

STM32WB P2P examle not working

Hi, i tried opening and debugging the STM32WB BLE-P2P example in my workspace but i dont get it to work. I tried a dozen ways to open and debug and even like in this video https://www.youtube.com/watch?v=WgsXMVZfoO8&list=PLnMKNibPkDnG9JRe2fbOOpVpWY7E...