MEMS (sensors)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

LIS3MDL magnetometer output becomes noisy after a bit

Dear community,I am trying to detect metalic objects (train axles) that are passing above two LIS3MDL sensors. For this purpose I am using LIS3MDL breakout boards from PololuWhat I notice is that often, what seems randomly, the signal becomes noisy d...

Screenshot 2024-02-08 130041.png
dburgt98 by Associate
  • 108 Views
  • 2 replies
  • 0 kudos

Problem with Unicleo GUI

Hello . I have to boards L476RG and 303RE and of course IKS01A3 . After installing Unicleo , I can't connect to that IKS (It's not even showing port )  . I'm changing boards but still It can't see it . On some tutorials some lady was coping some file...

Resolved! Handling of LSM303 unused pins

Hello,have designed in an LSM303AGR to replace an obsolete NXP chip, it used in I2C mode at 3.3V, and there are twopins that is not used, i.e. pin 7 - INT_MAG/DRDY and pin 12 - INT_1_XL.Upon testing, when the complete system is in sleep mode, we have...

AGI by Associate II
  • 249 Views
  • 6 replies
  • 0 kudos

MEMS: We want your knowledge base suggestions!

Dear community members,We invite you to provide your suggestions for knowledge base articles in this thread. We strive to create articles that can assist or inspire you in the best possible way.Anything goes, the only condition is that it is related ...

Magnetometer Sensor

Hi ST experts,  Can help to advise that 9axis (IMU+Mag) is a viable solution for indoor head tracking and positioning?There are multiple references stating that the magnetometer is prone to magnetic field interreference indoor and is suggested to ign...

Resolved! ILPS22QS data ready interrupt

Hi, I need clarification about interrupt on ILPS22QS barometric pressure sensor.My test project involves LIS3MDL and ILPS22QS connected to MSDA and MSCL on LSM6SDO, which is connected to an mcu in 4-wire SPI interface, to use sensor hub on LSM6DSO (I...

el659 by Associate III
  • 155 Views
  • 3 replies
  • 1 kudos

Resolved! IKS4A1 eCompass application with Unicleo-GUI

Hello, I am trying to test the e-compass application with the IKS4A1 connected to a Nucleo-F446 and Unicleo-GUI. The firmware of the Nucleo F446 was produced from Cube-MX following the "Getting started with the STMicroelectronics X-CUBE-MEMS1 softwar...

MRaff1_0-1706620923031.png
MRaff.1 by Associate III
  • 174 Views
  • 2 replies
  • 1 kudos

Resolved! Unicleo-GUI does not connect

Hello,    I am trying to test the compass of the IKS4A1 board with a Nucleo F446 board. I followed line by line the instructions provided in the "Getting started with the STMicroelectronics X-CUBE-MEMS1 software package for STM32CubeMX". My cube proj...

MRaff1_0-1706287076093.png
MRaff.1 by Associate III
  • 174 Views
  • 3 replies
  • 1 kudos

LSM303AGR X-CUBE-MEMS1

Hello,    I have a custom board with a STM32F373 and a LSM303AGR MEMS device.I made a Cube-MX project in which I included the corresponding x-cube-mems1 software pack with an eCompass application.The project compiles and runs. I see from the firmware...

MRaff.1 by Associate III
  • 131 Views
  • 2 replies
  • 0 kudos

Resolved! Setting sensor hub master i2c clock speed

Hi @Federica Bossi , I need help with setting LSM6DSO sensor hub i2c master clock speed. How do I set the master i2c clock speed between LSM6DSO and external sensor for sensor hub operation? Is there registers or something else on LSM6DSO that contro...

el659 by Associate III
  • 318 Views
  • 9 replies
  • 0 kudos