STM32CubeIDE (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! CubeIDE how to set offset for program?

I am making a DFU for stm32f4-discovery board.My DFU is using a project generated by STM32CubeMX V1.0. And It worked well with the program generated by the STM32CubeMX V1.0But when I worked with a project generated by STM32CubeIDE, I cannot make the ...

binhla by Associate II
  • 1425 Views
  • 4 replies
  • 1 kudos

Debug launch appears to end up in bootloader

I have a NUCLEO-L4R5ZI board with an STM32L4R5ZIT6P MCU. I have been successfully building and debugging using CubeIDE 1.9.0 with a USB connection to the onboard ST -LINK debugger. However, I've suddenly encountered a situation where after the debug ...

Resolved! STMCubeIDE gives the message "Break at address "0x1fff5162" with no debug information available, or outside of program code."

Hello. I work in CubeIDE 1.9.0 with the stm32f429i-disco device. The problem arises about firmware and debugging. I made a simple example to check. During debugging, strange behavior was noticed when executing HAL_Delay (line 95). When executing Step...

DalOpez by Associate II
  • 3148 Views
  • 3 replies
  • 0 kudos

Resolved! Dual bootloader - how to?

Hi everyone!I have to implement a dual bootloader system on different stm32 microcontrollers in STM32cube ide, and I have some questions…The idea is the following:There is a “pre-bootloader�? at the beginning of the flash. When it starts, it gets som...

Resolved! Combining Bootloader and Application Code via Batch script

Hello,I am building a project using a batch script which is calling stm32cubeidec.exe to build the separate entities. The project contains a bootloader as well as main application code. I am wondering the best way to combine the two binary files in t...

LGree.3 by Associate II
  • 1331 Views
  • 5 replies
  • 0 kudos

Locate Constant Data in Flash at Fixed Address

Yet another question on locating data, this time fixed in flash. I want to place some main application attributes at a fixed flash location so that my bootloader can learn about the installed app. I have had partial success. (For now this is for an S...