STM32CubeIDE (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

How can I install STM32CubeIde on Linux Debian 12?

I start the installation of STM32CubeIde on Debian 12, but it is impossible to continue the installation because it needs libpython2.7 and I have python3 installed on system. I can't downgrade the system.How can I do?Thank you

Diego1 by Associate II
  • 3722 Views
  • 10 replies
  • 8 kudos

Can't install STM32CubeIDE in Ubuntu 23

Getting the below error while installing The following packages have unmet dependencies: st-stm32cubeide-1.12.1 : Depends: libpython2.7 but it is not installableE: Unable to correct problems, you have held broken packages.

Raees by Associate II
  • 4376 Views
  • 9 replies
  • 7 kudos