STM32CubeIDE (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

hrlp! - debug as says (none applicable)

I'm trying to run a simple blink sketch using a F031K6 nucleo board. I'm following the steps here - https://www.youtube.com/watch?v=hyZS2p1tW-g and when i get to the part where I go to 'debug as' I can't because it says 'none applicable'. I have the ...

deep_rune by Associate III
  • 578 Views
  • 9 replies
  • 0 kudos

I am having debugging issues with STM32CubeIDE. the processor is STM32F030F4Px and I am using a knock off ST-Link V2. It seem that no matter what I configure I get the same error. There also is a check GDB server version error in the IDE window.

Open On-Chip Debugger 0.12.0-00017-gb153daa14 (2023-02-03-14:58) Licensed under GNU GPL v2Info : Listening on port 6666 for tcl connectionsInfo : Listening on port 4444 for telnet connectionsInfo : STLINK V2J41S7 (API v2) VID:PID 0483:3748Info : Targ...

DHirs.2 by Associate
  • 499 Views
  • 1 replies
  • 0 kudos

Resolved! Nucleo-STM32f030 ADC setup Issues This code only works when I'm debugging step by step. Otherwise, it always sends ADEN low again, which should not happen!!

This code only works when I'm debugging step by step. Otherwise, it always sends ADEN low again, which should not happen!! (Correct sequence: ADEN goes high then ADRDY goes high and both stay high...) (Note both ADEN and ADRDY are low before line 54 ...

0693W00000YAXrPQAX.png 0693W00000YAXsWQAX.png
OSell.1 by Associate II
  • 642 Views
  • 7 replies
  • 1 kudos