STM32CubeIDE (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

CubeIDE doesn't start a workspace

Hi,While trying to open a project inside a workspace the CubeIDE stopped loading:As you can see from the log, nothing happen after a while, CPU isn't used at all, and my OS gives me the option to exit the application. You can also see a drop in RAM u...

Captura de pantalla de 2024-03-25 22-16-16.png
XR.1 by Associate III
  • 200 Views
  • 5 replies
  • 1 kudos

IOC project doesn't render completely in CubeIDE

After 100 attempts to open the IOC project inside the CubeIDE it opened but only a half, which makes it unusable, what can I do?CubeIDE/Java is eaten all my CPU, but they aren't doing any useful work, help please! 

Captura de pantalla de 2024-03-25 21-51-51.png
XR.1 by Associate III
  • 115 Views
  • 0 replies
  • 0 kudos

HAL_I2C_Master_Transmit_IT error in the Hal lib?

I am using the HAL library generated with the STM32CUbeIDE for controlling a I2C sensor.With the demoboard nucleo stm32l031k6I am using the HAL interrupt master transmit functionbut the byte’s send aren't the ones that I attach.While debugging I see ...

Multiple "expected expression before 'do'" errors

I'm new to STM32 and trying to bring up the STM32L053-DISCO project in STM32CubeIDE. It mostly comiles fine, but has an issue with the HAL defines, such as below:#define __HAL_RCC_GPIOA_CLK_ENABLE()  do { \                    __IO uint32_t tmpreg; \ ...

SHoll.1 by Associate II
  • 1633 Views
  • 12 replies
  • 1 kudos

Problems with STM32IDE together with NUCLEO-L010RB

HelloI've been using the STM32IDE (Windows version) along with NUCLEO 144 boards for 8 months. Now I bought a NUCLEO-L010RB and created a standard project without user code. The build was successful. The program call via RUN and DEBUG generates the f...

_legacyfs_online_stmicro_images_0693W00000bketuQAA.png
RMoeh.1 by Associate II
  • 317 Views
  • 3 replies
  • 0 kudos

Host process of CDC (Virtual Port Com) does not work.

I am using STM32G0B1KC to make a CDC class USB Host.I selected in STM32CubeIDE, Mode=Host_Only (FS) in Connectivity - USB_DRD_FS and Communication Host Class (Virtual Port Com) in Middleware - USB_HOST.Before creating the user program, I checked the ...

JJ4IQV by Associate
  • 678 Views
  • 7 replies
  • 0 kudos

Resolved! How to open Keil Project to STM32cube IDE?

I am not a programmer and beginner in Embedded software, I recieve a keil project from another person. I need to change some parameters in the project. I have STM32cube IDE with debugger. So how to open the keil project with its file to STM32cube IDE...

TReaz.1 by Associate II
  • 1030 Views
  • 6 replies
  • 0 kudos

Tried stepbystep (Intro to UART) from stm32 website, build and debugging are a success but keeps shutting down before even sending out "HelloWorld" to TeraTerm. What could be the problem?

Hi all, im a beginner on stm32 (currently using l703rz) to play with. I have tried the code from stm32 stepbystep (Intro to UART), the build and debugging are a success. The problem is that it keeps shutting down after debugging and would not send ou...

LGuan.3 by Associate
  • 441 Views
  • 3 replies
  • 0 kudos