STM32CubeProgrammer (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

DEV_TARGET_HELD_UNDER_RESET error from ST-LINK

I'm a complete newbe at directly programming STM and am learning using a Nucleo-l476RG board. When I try and run my code from STMCubeIDE I get errors failed to execute MI command and then "the system tried to join a drive to a directory on a joined d...

G0MGX by Associate
  • 3441 Views
  • 9 replies
  • 3 kudos

Resolved! STM32_Programmer_CLI.exe question

I have a custom board with STM32G070RB micro. I programmed the board several times for debugging in the development phase using theST-LINK//V2 in CubeIDE.Now I would like to generate a .bat file to program the boards, but I am facing some problems.My...

tabekb by Associate III
  • 2667 Views
  • 14 replies
  • 4 kudos

Resolved! Downgrade STM32CubeProgrammer in STM32CubeIDE

STM32CubeProgrammer v2.13 was giving me the famous "Failed to execute MI command" and "Failed to download Segment[0]" errors within the STM32CubeIDE, so I downloaded the standalone STM32CubeProgrammer v2.10 and it works fine. The IDE still uses v2.13...

CCend.2 by Associate III
  • 755 Views
  • 3 replies
  • 0 kudos

How to download ELF file to a STM32L4R9 board that I could program a few weeks ago but can't now - it didn't just stop working, it got worse.

Programming my board worked fine for a long time, but then it started to fail with the error messages shown below but I could get it working again by closing the IDE (STM32CubeIDE) and unplugging the ST-Link/V2 then plug in and restart the IDE - but ...

IHodg.1 by Associate
  • 687 Views
  • 3 replies
  • 0 kudos

GDPR compliance of CubeIDE and CubeProgrammer?

I just downloaded and installed both STM32CubeIDE and STM32CubeProgrammer.They both forcibly installed with user-spying phone-home features how I use the software, while only mentioning how to disable the feature after they have been installed.So, th...

SOlen.1 by Associate II
  • 544 Views
  • 8 replies
  • 3 kudos