STM32CubeProgrammer (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

obDisplay API crashes

Hi,I'm trying to create a wrapper for STM32CubeProgrammer_API.dll.The program crashes on trying to use the obDisplay API. I've tried using STM32CubeProgrammer_API.dll versions 2.10 and 2.15. Is there something I'm missing?Thank you very much.

DEV_TARGET_HELD_UNDER_RESET error from ST-LINK

I'm a complete newbe at directly programming STM and am learning using a Nucleo-l476RG board. When I try and run my code from STMCubeIDE I get errors failed to execute MI command and then "the system tried to join a drive to a directory on a joined d...

G0MGX by Associate
  • 3401 Views
  • 9 replies
  • 3 kudos

How to download ELF file to a STM32L4R9 board that I could program a few weeks ago but can't now - it didn't just stop working, it got worse.

Programming my board worked fine for a long time, but then it started to fail with the error messages shown below but I could get it working again by closing the IDE (STM32CubeIDE) and unplugging the ST-Link/V2 then plug in and restart the IDE - but ...

IHodg.1 by Associate
  • 682 Views
  • 3 replies
  • 0 kudos

Resolved! How to enter ST USART Bootloader from Code?

Im trying to jump to bootloader section from my Code. I'm trying to update the firmware over USART with the intergrated bootloader. In my application I'm using USART2 (PA2/PA3) on a STM32L431CCU6 Microcontroller running native FreeRTOS. My Code to in...

_legacyfs_online_stmicro_images_0693W00000biZdlQAE.png