STM32 MPUs Embedded software

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Using Jtag/SWD in Linux

Custom PCB, STM32MP157C chip. Linux 5.7.10. Buildroot build. No issues - Linux boots to console prompt without trouble, no errors. I can view device registers and all memory regions using Segger Jlink via SWD in both SPL and UBoot. Once Linux starts ...

info by Associate II
  • 571 Views
  • 1 replies
  • 0 kudos

Compiler Bug?

I ran into a warning for one section of code that I did not for a different section of code. So I simplified it into two function. I don't see why I get a warning for one and not the other.void test32(uint32_t *data) { uint32_t src_addr = (uint32_t...

STM32MP1 FreeRTOS debug issue

Hi,We are currently using the STM32MP1-DK1 board.We have tried several examples but we are facing some issues with the one using FreeRTOS (FreeRTOS_ThreadCreation) :We have no issues running the program on the M4 both in Engineering mode and Producti...

romain2 by Associate III
  • 744 Views
  • 4 replies
  • 0 kudos