STM32 MPUs Embedded software

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! Linux "gpio-poweroff" won't load

I'm trying to add the linux "gpio-poweroff" function to the distribution package. I've added the following to my device tree:gpio-poweroff { compatible = "gpio-poweroff"; gpios = <&gpioe 1 GPIO_ACTIVE_HIGH>; timeout-ms = <3000>; };The kernel/devic...

allard by Senior
  • 763 Views
  • 7 replies
  • 0 kudos

Resolved! Conflict between ethernet and PMIC

I used this post https://community.st.com/t5/stm32-mpus-products/stm32mp151aac-custom-board-kernel-not-starting/td-p/587192 to figure out how to add interrupts to pmic and got my board to finally boot into Linux.  I then added my ethernet to the dts ...

dkal by Associate III
  • 272 Views
  • 1 replies
  • 1 kudos

Resolved! GPIO Interrupt / EXTI setup in device tree

I have the following DTS file and I have not been able to get the GPIO external interrupt working correctly. I have read this document on interrupt overviews, and tried to enable the EXTI to have control of the GPIOB pin 12. /dts-v1/;   #include "stm...

scotty by Associate II
  • 1386 Views
  • 2 replies
  • 0 kudos

STM32MP1 DTS file pin pull up

I've tried following the examples given here and here, but it will not work. I just want to enable a pull up resistor in the DTS file. Here is my DTS file. If anyone can please tell me why it's not working I would appreciate it. /dts-v1/;   #include ...

scotty by Associate II
  • 534 Views
  • 5 replies
  • 0 kudos

Resolved! GPIO programming issue

Hi all ~I'm trying to control GPIO input in own application. and I refered to below wiki. https://wiki.st.com/stm32mpu/wiki/How_to_control_a_GPIO_in_userspace​this is my code. gint gpiochip_fd, ret; gchar gpiochip_path[20]; struct gpioevent_request i...

Resolved! Can't blink a LED on STM32MP157-DK2

I'm now trying to blink a LED on my STM32MP157-DK2 board.I have managed to run and even modify the GPIO_EXTI example, but I'd like to do this from scratch.1) I first created a project using CubeMX and wrote my code in the IDE.It seems that I can't us...

FAuza.1 by Associate III
  • 663 Views
  • 4 replies
  • 0 kudos