cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with IDE

Grzesi3k777
Associate II

Hello, 

I've got problem with STMCubeIDE. You can see my problem at photos I attached. Can anyone help me to solve this problem. I try to work on Lenovo Legion 5 with Ryzen 5 5600h and RTX3060. Second graphic card is integrated with Ryzen CPU. 

This problem is at lot of windows at MX section when I try to configure my STM. I try to open this program with both graphic cards. I have latest drivers to both graphic cards. Try to standalone MX software but still same result. 

Maybe someone had similar problem.

18 REPLIES 18
Semer CHERNI
ST Employee

Hello @Grzesi3k777 

First let me thank you for posting.

To be able to further investigate the issue, I will need you to provide:

  • A project or just an ioc file which led to this issue
  • The STM32CubeIDE version you are using
  • Which Windows version you have installed
  • The log files from STM32CubeIDE : the.log and the .ide.log (found under workspace/.metadata)
  • The log file from STM32CubeMX : the STM32CubeMX.log (found under user/.stm32cubemx)

BR,

Semer.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Grzesi3k777
Associate II

Hello Semer, 

thank you for your answer. For now I cannot answer to all your question but: 

1. I am using Windows 11

2. STM CubeIDE I am using the latest version 

3. Do you really need my IOC file? There is nothing for now because I create it for test to show the problem. 

I don't have logs for now. You have to know that I tried CubeIDE at another computer with Windows 11 and I don't have this problem so it is not problem with OS. Maybe something in my computer maybe some drivers or something. I hope that you can help me with this topic. 

AScha.3
Principal III

hi, 

i have also a problem (on win PC ) when opening MX/ioc view - window is in pure white .

(this strange problem was suddenly beginning some month ago)

but closing this MX window and open again (just click on ioc file) starts it correct. so did you try this ?

If you feel a post has answered your question, please click "Accept as Solution".

Hi, 

I didn't try it. So I have to try to reopen ioc file. I have to back home to test it so I'll let you know later. 

Grzesi3k777
Associate II

Hi, 

I tried your suggestion and unfortunatelly still have a problem. I reopen ioc file and still have this weird problem. 

Grzesi3k777
Associate II

Do you maybe have any new suggestion how to solve this weird problem? 

Hi, 

How can I make this log file for you? 

Grzesi3k777
Associate II

Hello,

Can anyone help me with this weird problem? 

Herve PIERROT
ST Employee

Hi @Grzesi3k777 ,

Sorry for such inconvenience.

I'm not sure it can provide you a workaround, but could you please have a look to this post that seems
similar to your case and where an update of the Windows display setting (probably talking about font size and
display scaling) helped :
https://community.st.com/t5/stm32cubemx-mcu/my-cubemx-ui-is-messed-up/m-p/571509/highlight/true#M25330

Let me know if that could work for you too.