STM32 MPUs products

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

STM32MP1 - Bare metal on A7

Hi,I have a current project using the M7 that I need to port over to the A7. The goal is to be running bare-metal code on the A7, like we are on the M7. Currently, I am following this open source guide to run bare-metal on the A7 and it seems to work...

mkurtz by Associate II
  • 611 Views
  • 6 replies
  • 0 kudos

Resolved! Urgent: Cannot boot from NAND - OTP

Problem: After configuring the OTP pins in word 3 to the following:- Primary boot source : SD-card- Secondary boot source : FMC NANDAnd flashing the FMC nand with TF-A `tfa-*-nand.stm32` in the first sector using `nandwrite -p /dev/mtd0 /mnt/boot/tf-...

JOhn1 by Associate III
  • 697 Views
  • 5 replies
  • 0 kudos

Resolved! FIP Secure Boot Can't Find Key

I've followed this walkthrough perfectly: https://wiki.st.com/stm32mpu/wiki/How_to_perform_Secure_Boot_from_Distribution_package#Distribution_package_with_signed_FIPand I get a "Not able to find "None" (socname stm32mp15) path from current BBPATH var...

bblouin by Associate III
  • 347 Views
  • 2 replies
  • 1 kudos
DPade.1 by Associate III
  • 385 Views
  • 3 replies
  • 0 kudos

Resolved! Inaccurate measurement of VREFINT

Hi everyone!I see unexpected values when measuring VREFINT. The ADC measures around 1.18V, on some boards even 1.16V, which is outside the tolerance according to the datasheet: Reading the calibration value VREFIN_CAL from OTP memory returns a value ...

0693W00000QLsweQAD.png 0693W00000QLsozQAD.png
jvog.sen by Associate II
  • 743 Views
  • 7 replies
  • 0 kudos

How to protect Bootloader binary on STM32MP15xxx

Hi,We see signing + encryption bootloader on STM32MP13xx,But on STM32MP15xx, there is only signing. The raw binary still start from offset 256 of the signed file. This only make sure the board doesn't run a strange bootloader, but doesn't prevent som...

Dat Tran by Senior II
  • 178 Views
  • 1 replies
  • 0 kudos

gdbgui always open web browser and failed

When i tried the commend below (<Your_full_path_to> was already corrected to the path that content Setup.gdb), ```gdbgui -g "arm-ostl-linux-gnueabi-gdb -x <Your_full_path_to>/Setup.gdb"```I would like to use ST-Link for debug uboot, but the web brows...

Dat Tran by Senior II
  • 316 Views
  • 2 replies
  • 0 kudos