STM32 MPUs products

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

STM32MP133D optee issue.

Hello.I am on porting STM32MP135F-DK Discovery Board source to STM32MP133D based customizing board.With bitbake build, the firmwares work well with STM32MP135F-DK.But with our developing board, it stuck on BL2 boot with panic. The main difference is ...

capture.JPG
ritoseo by Associate
  • 336 Views
  • 2 replies
  • 0 kudos

Resolved! STM32CubeIDE on Windows 7

HelloI tried everything but I cannot get STM32CubeIDE to get the editor to work.I just keep on getting this message: There is no active editor that provides an outline.I spent hours re-installing but nothing workedAll help will be appreciated

techdesk by Associate III
  • 266 Views
  • 10 replies
  • 1 kudos

Resolved! bitbake build error - package openocd

Hi ,i'm trying to build st-image-weston for target board STM32MP135F-DKrepo init -u https://github.com/STMicroelectronics/oe-manifest.git -b refs/tags/openstlinux-5.15-yocto-kirkstone-mp1-v22.11.23repo syncDISTRO=openstlinux-weston MACHINE=stm32mp13-...

Resolved! compilation error of kernel in previous ecosystem 4.1

Hi,i'm trying to compile kernel from Ecosystem 4.1 , i'm downloading :https://www.st.com/en/embedded-software/stm32mp1dev.html#get-software... version 4.1.0, kernel is linux-stm32mp-5.15.67-stm32mp-r2-r0/linux-5.15.67error from compilation :   HOSTC...

Resolved! STM32MP157 GPIO access

Hi team,I have an STM32MP157 board with a Cortex-M4 processor. I have a simple task, which is to toggle the GPIO at maximum speed with accuracy, ensuring that the clock width does not vary.The maximum toggle speed we require is approximately 15ns bet...

Resolved! STM32MP135 - BAREMETAL - UART - DMA

Hello, I am currently using bare-metal MP13 solution in CubeIDE. I want to integrate uart with DMA. After configuring DMA settings for uart4, a following fragment of DMA init code has been generated:NVIC is not available for Cortex-A, but still its f...

jschneider_1-1704878867812.png

Resolved! TF-A hangs on stm32mp157d-dk1

Hello all, As part of the evaluation of the 32MP15 series, I was trying to build the u-boot and TF-A binaries. I tried the u-boot SPL bring up and it seems to be working fine (except for failure to launch the Linux Kernel, as per your late updates). ...

Booting custom STM32MP151fAC1 board

Hi All, I'm trying to boot a custom board using the Starter Package through the STM32CubeProgrammer. I'am flashing the SD Card on the board through the UART interface as USB interface(CN7/USB_OTG) is not provided for the board. During this process I'...

MicrosoftTeams-image.png
prik_29 by Associate
  • 528 Views
  • 4 replies
  • 1 kudos

Resolved! STPM4RasPI for STM32MP135F-DK - SPI timeout error

Hi, I would like to integrate the STPM4RasPI with MP135F-dk. After following the https://wiki.st.com/stm32mpu/wiki/STPM4RasPI_expansion_board tutorial, I am receiving an error. Driver is enabled:STPM4RasPI module is properly attached. Do you have any...

jschneider_1-1701174477269.png jschneider_0-1701175073672.png