STM32CubeIDE (MPUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

STM32CubeIDE 1.15.1 released

STM32CubeIDE 1.15.1 was released on st.com as well as an in-tool update patch aligned with STM32CubeMX v6.11.1 that is available for download. Main issues fixed in this patch: Ticket 177978 : Fixed an issue with ST-LINK firmware upgrade concerning th...

STM32CubeIDE 1.15.0 released

STM32CubeIDE 1.15.0 was released today on st.com as well as an in-tool update patch. What is new in 1.15.0? Microcontroller and board lists aligned with STM32CubeMX v6.11.0 : STM32U0, STM32H7Rx/STM32H7Sx and STM32H523/STM32H533Added the support for t...

Resolved! openSTlinux build from stm32cubeide to sdcard image

I've build all part (linux, tf-a, u-boot) in stm32cubeide, acording to my device tree configured in cube.I would like to ask if there is short way to create sd-card image from cube gui? If not, could any one share way how to do that from build to rea...

TStas.1 by Associate
  • 697 Views
  • 6 replies
  • 1 kudos

Resolved! Any chance STM-IDE to support Pkg-Config tool?

Pkg-Config is not supported by STM-IDE ,and cannot be installed. This tool really speeds up the library selection process. Perhaps somebody know any alternatives that STM-IDE does support?URL:https://marketplace.eclipse.org/content/pkg-config-support...

SSH Connection to STM32CUBEIDE

Hi,How can I connect to STM32MPU via SSH from inside STM32CUBEIDE.?? Is there a way we can do that?This really helps in live debug of things.Alternatively is there a way I can live debug an application running on A7?

NPal.2 by Senior
  • 534 Views
  • 3 replies
  • 0 kudos

stm32mp1 uart noise rx

Hi All,i am using stm32mp1 cpu,, recently i m facing floating rx issue on debug uart, with physical debug cable , i could default state of RX lines were pull up, and when i remove the cable, the RX lines is floating and its voltage fluctuates between...

Ara.1 by Senior
  • 648 Views
  • 5 replies
  • 0 kudos

location of target/stm32mp1x.cfg on Windows

I want to use the STM32CubeIDE to debug the M4 on the STM32MP1.I setup the debug setting for debug probe ST-Link (OpenOCD). If I use the automated generation of the script, it refer to [find target/stm32mp1x.cfg].This is not part of the default insta...