STM32CubeIDE (MPUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

STM32CubeIDE 1.15.0 released

STM32CubeIDE 1.15.0 was released today on st.com as well as an in-tool update patch. What is new in 1.15.0? Microcontroller and board lists aligned with STM32CubeMX v6.11.0 : STM32U0, STM32H7Rx/STM32H7Sx and STM32H523/STM32H533Added the support for t...

STM32CubeIDE for OSX for MP1

Is it possible to use the CubeIDE on OSX for debugging firmware for STM32MP1?The interface is lacking some features and the debugging configuration is completely different.Also I can't manage to make it work.Here is what shows up when I launch Debug ...

0693W00000ANb7ZQAT.png
Sindel by Associate
  • 310 Views
  • 3 replies
  • 0 kudos

Good afternoon. Using CubeMX, I created an empty project for the STM32MP157A-DK1 board. It compiles without errors. But when I try to start debugging in engineering mode, I get a message that there are too many breakpoints. When I try to start debugging i

Good afternoon. Using CubeMX, I created an empty project for the STM32MP157A-DK1 board. It compiles without errors. But when I try to start debugging in engineering mode, I get a message that there are too many breakpoints. When I try to start debugg...

Vlaty.1 by Senior
  • 252 Views
  • 2 replies
  • 0 kudos

STM32MP1 always fails on HAL_RCC_OscConfig

Hi,   I just approach to STM32MP1 and want to port some project from STM32F4/L4 to M4 Core in STM32MP1.   To start, I'm just trying use engineering mode fisrt. I have a STM32MP157C-DK2 board and a new project is generated by STM32CubeMX, all configur...

Resolved! The stm32cubeide v1.1.0 hasn't load image option on macos

Hi supporter,I use STM32Cube v1.10 on macos(Mojave) and linux(debian 9). The debug dialog has load mode option to choose production or engineering mode in stm32cubeide on linux system. But that dialog hasn't the load mode on macos.Below picture is de...

0690X00000BvtBbQAJ.png
SChen.11 by Associate III
  • 1078 Views
  • 10 replies
  • 0 kudos

How can i enable SPI5 on STM32MP157-DK1

Hi,Im working with STM32MP157A-DK1 board. Im working on the linux side, need to write C/C++ code for saving data into a SD card. I need to use SPI to get data from RF transceiver. I built linux and kernel as in this link:https://wiki.st.com/stm32mpu/...

MÇerçi by Associate III
  • 542 Views
  • 3 replies
  • 0 kudos

STM32MP157C-DK2 M4 debugging issues.

Hi, I have 10 DK2's in a server rack for development and testing. STM32CubeIDE (1.5.0) debugging wants me to specify a serial port and an IP address for debugging. This is IMHO redundant, why? Moreover, the serial ports /dev/ttyACM* are to be selecte...

KnarfB by Principal III
  • 343 Views
  • 2 replies
  • 0 kudos