STM32CubeIDE (MPUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Debugging with STM32MP135-DK

Hello,following this wiki article I'm trying to debug the sample user space application, but getting this error:It seems, I have a working serial and SSH connection to the target but the Target Status widget always shows 'Serial console in use':My De...

Screenshot 2024-03-28 112807a.png Screenshot 2024-03-28 113928.png Screenshot 2024-03-28 114311.png
ali7 by Associate II
  • 136 Views
  • 3 replies
  • 0 kudos

STM32CubeIDE: CPU stuck at 100% when editing IOC files

I am using STM32CubeIDE v1.4.2 and experiencing issues with editing IOC files. I am using Ubuntu 18.04.05 as recommended by ST. Often when when I am using the integrated Cube MX editor I experience 100% CPU load and the IDE locks up. I have tried inc...

AStev.2 by Associate III
  • 1408 Views
  • 19 replies
  • 0 kudos

STM32CubeIDE 1.15.0 released

STM32CubeIDE 1.15.0 was released today on st.com as well as an in-tool update patch. What is new in 1.15.0? Microcontroller and board lists aligned with STM32CubeMX v6.11.0 : STM32U0, STM32H7Rx/STM32H7Sx and STM32H523/STM32H533Added the support for t...

Failed to debug mp157-m4 through linux core

when I wanted to debug mp157-m4 through linux core,I got a failed returnthe reason why it failed was the fw_cortex_m4.sh script had no excutive permissionI tried chmod +x for getting permission,but the next time I clicked the debug btn and I found it...

suffering_0-1710250888432.png suffering_1-1710251073167.png

No such file or Directory but file was included

Hi, I am having trouble building my ISPU project. When I attempt to build i get 3 errors:1- fatal error: neuton_generated/neuton_user_types.h: No such file or directory ispu line 13, external location: C:\Human_Movements_Recognition_8_float_off_scale...

image.png image.png image.png

Resolved! DDR_Init_A7 unable run

DearsI can only start this example in Debug mode, the BLUE led start blinking... So it works OK.But If I try to use RUN command (using icon, or right mouse click on project file) than it seems not work (RED leds blinks only ONE and is OFF, Blue LED i...

ravo by Associate III
  • 365 Views
  • 4 replies
  • 1 kudos