cancel
Showing results for 
Search instead for 
Did you mean: 

Jumping to random file after pressing Run button

GeneralTao
Associate II

Hello. When I press to Run (Run main.c) button, STM32CubeIDE opens random file, possibly, from current repository, for example: startup_stm32l452xx.s, core_cm4.h etc...

Code is loading successful, but this side effect bothers me.

I would like to disable this function. How can I do it?

If you need more information about this behavior please, ask.

Thank you for reading.

92 REPLIES 92

The "(Community Member)" yueri.1 is registered since today, 28.05.2023 and has already posted 3 comments to different topics, all in chatgpt style: lengthy, imprecise and useless.

Either one is trying to quickly acquire points by citing chatgpt or it is a chatgpt-family bot. Ban!

The same here. After many debug sessions my IDE is full of unwanted opened files. Very annoying.

Looks like a long-playing problem ...

Version: 1.12.1

Build: 16088_20230420_1057 (UTC)

PHolt.1
Senior II

Version 1.13 does the same.

Lukasz Nowak
Associate III

I have had this problem for many versions, including 1.13 (on Windows 10). Run launches, freshly after opening the IDE work fine. But after the first Debug session, the random files open on every Run launch, until the IDE is restarted.

It is extremely annoying.

If ST have difficulty recreating this, I can check anything on my machine - do ask.

Gaston_78
Associate

Looks like from STM nobody cares this issue.. 🙄  which is very annoying, with full opened tabs after programming/RUN several times

 

Mkotb
Associate II

Still No fix for this issue !?

JCHABOD
Associate

In my understanding, this simply occures because when you upload your ELF, the debugger connects, interrupts the current execution and thus opens the file matching with the current location of the program. (And yes, this is boring, but this is what you expect all the time except while downloading...)
I would guess this is eclise-related rather than STMCube...

Lukasz Nowak
Associate III

Just to verify a couple of things, I did a fresh install of Linux Mint 21 and a fresh install of STM32CubeIDE 1.13.1. And the problem happens there as well. So it is not a Windows thing. And it is nothing left-over from any older version previously installed.

And as mentioned earlier, the first Run after starting up the IDE does not show the problem. Only after the first Debug session it starts happening until the IDE is restarted.

I have the same problem

Eldar
Associate II

Still the same problem Version: 1.14.0