STM32 MPUs products

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

STM32MP1 - Bare metal on A7

Hi,I have a current project using the M7 that I need to port over to the A7. The goal is to be running bare-metal code on the A7, like we are on the M7. Currently, I am following this open source guide to run bare-metal on the A7 and it seems to work...

mkurtz by Associate
  • 73 Views
  • 5 replies
  • 0 kudos

How does one get Ubuntu onto a STMP32MP1?

Hi everyone, I recently picked up a STM32MP157F-DK2 board and trying out this embedded linux. Very new to it all.I did some research and it looks like the traditional way is to use one of the build systems, such as buildroot to create your own distri...

CLeo.1 by Senior II
  • 831 Views
  • 2 replies
  • 0 kudos

Resolved! cups and hplip printing error with Stm32mp157 usb.

Hello:​I installed 'cups' and 'hplip', and successfully installed HP_ LaserJet_ 1010 driver through 'hp-setup', but when I print files through 'lp', the printer doesn't respond, and a 'filter failed' error occurs. I want to install hplip-3.19.12-plug...

zxiao.4 by Associate III
  • 508 Views
  • 5 replies
  • 0 kudos

Resolved! Kirsktone support

HelloI was wondering if you planned to support kirsktone (next yocto LTS) supposed to be released soon. Do you have any info on the port?Thanks

syedelec by Associate III
  • 446 Views
  • 3 replies
  • 0 kudos

I have an STM32MP157F-DK2 and am attempting to create a build using Yocto. I am using meta layers poky, openembedded, and st-stm32mp. I can build core-image-minimal. This build lacks WiFi and USB OTG which are needed.

The image that comes with the board has WiFI and USB OTG working. I am adding additional networking (VPN, firewall) to my Yocto build. I have attempted to build core-image-base and am able to see the wlan0 adapter but something in that build is disab...

KBarr.1 by Associate
  • 183 Views
  • 0 replies
  • 0 kudos

Resolved! GPIOF and GPIOG not working on STM32MP151

Hi STM-Community,I'm having problems getting to work the GPIOS of the banks F and G of the STM32MP151DADX with the TFBGA257 Package.Firstly, I see the following error at boot time: [ 1.527623] stm32mp157-pinctrl soc:pin-controller-z@54004000: at l...