Showing results for 
Search instead for 
Did you mean: 

Can't install V2.16.0 in Debian/Raspbian Linux - installer insta-quits

Associate III

Per the title really - I've just tried to install the Linux version on a raspberry pi running Raspbian / Debian 11.7 'Bullseye' and, well, NOTHING happens.

If I click 'SetupSTM32CubeProgrammer-2.16.0.linux' nothing happens at all, if I select "execute in terminal" I get a brief flash of a terminal window, a mystery file of 0 bytes is created (named with a single unicode character and 'P').

If I run it from the terminal I get:

$ ./SetupSTM32CubeProgrammer-2.16.0.linux
-bash: ./SetupSTM32CubeProgrammer-2.16.0.linux: cannot execute binary file: Exec format error



Also why is a tool for programming microcontrollers a 286Mb download for which we must give ST our blood type and inside leg measurement just to be allowed to download it? 😳

ST Employee

Hello @JU ,


Currently STM32CubeProgrammer does not support ARM platforms. This request has already been raised to the development team. I will make sure to keep you informed of any advancements regarding this issue.

Internal ticket number: 162152 (This is an internal tracking number and is not accessible or usable by customers).