Showing results for 
Search instead for 
Did you mean: 

H743 - SWO not working - PB3 floating

Associate II

I still struggle with SWO on a custom board with two H743s on it. No matter what I try, SWO pin PB3 is floating. I could get the SWO of a H743 Nucleo board with the hack of clive1 in this post below work a few years ago, but with current firmware/CubeMX/STLINKv3, I can't make it work again...

What I tried:

  • In the CubeMX, I set "Trace Asynchronous Sw" enabling it PB3 (SWO).
  • I tried the code of Clive1 in the post above, there PB3 will also be enabled, clock will be activated etc.
  • Tried several SW and Clock speeds.
  • As soon as I try to activate SWO, CubeIDE freezes, debug connection gets lost.
  • I'm using the standard printf implementation on syscalls.c. Tested that strings arrive to FIFO and _write() gets triggered.
  • I'm using ST-Link V3. Flashing/debugging work well at 24MHz both using SW and JTAG.

Can somebody please help me to make my SWO (PB3) initialize correctly? Which part of API does that? Is it implemented at all?