Showing results for 
Search instead for 
Did you mean: 

Unable to install CubeL4 version 1.15.1 (patch) in CubeMX

Bob S

Running CubeMX version 5.6.1 on Win10. No internet connection, so I manually copy the CubeL4 zip files to the PC and then try to install via the "Install/Remove" button under software packages. I have CubeL4 1.15.0 installed. When I check 1.15.1 and click on "From Local", and select the ZIP file, I get this error:

"Missing dependency for this package. - STM32Cube FW_L4 V1.15.0"

I uninstall 1.15.0, then re-install 1.15.0, same error. Uninstall 1.15.0, try to install 1.15.1, same error.

I manually un-zip'd the 1.15.1 on top of the 1.15.0 directory tree. Now CubeMX shows 1.15.1 installed (checked) and 1.15.0 not installed. Is this a valid configuration? Or do I need to find another way to install 1.15.1 through CubeMX?

Khouloud ZEMMELI
ST Employee

​Hello @Bob S​ 

Thanks for your feedback , this will be internally checked,

Otherwise,  try to install and unzip the FW in your repository (I think as you did) then CubeMX will take the latest available FW package version, it's valid

Best Regards,