Showing results for 
Search instead for 
Did you mean: 

Working of FDCAN module in M4 core in STM32H747I-DISCO board.

Associate II

"Hello, I'm currently working with the FDCAN module on the STM32H747I-DISCO board. I've successfully configured both FDCAN modules in the M7 core, and they are working as expected. However, when attempting to configure them in the M4 core independently, I encounter issues – the FDCAN modules do not work reliably. Interestingly, if I first call the Init and Start functions for both FDCAN modules in the M7 core, then the modules in the M4 core start working. Nevertheless, this behavior is inconsistent. Can anyone provide insights into what might be causing this issue ? Thank you!"

ST Employee

Hello @Pavankumar1_ 

I advise you to check this post which contains STM32H747 FDCAN project running on M4 core.

Solved: FDCAN transmit and receive not working in M4 core ... - STMicroelectronics Community

Hope my answer helped you!

When your question is answered, please close this topic by clicking "Accept as Solution".


Why you opened a new thread for the same subject from this thread?

It didn't solve the issue? did you try the FW shared on this thread?

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.