Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE & MX integrated

Associate III
I have some problem with STM32CubeIDE, since when I start a new project everything works well as long as I delete the file: 
However, when I exit the project, closing STM32CubeIDE, and I reopen it, recalling integrated MX, either a blank page or the MCU only is shown. I'm not allowed to do anything.
STM32CubeMX standalone works correctly, without problems.
I tried to find some solution online, nothing works but deleting the file indicated above and restart the project 
Here's my system informations:
Computer HP HP 250 G5 Notebook PC
SSD 500 GiB
Memory 8.0 GiB
Processor Intel® Celeron(R) CPU N3060 @ 1.60GHz × 2
Graphics card Mesa Intel® HD Graphics 400 (BSW)
O.S. Ubuntu 22.04.1 LTS 6.2.0-31-generic #31~22.04.1-Ubuntu
GNOME version 42.9
Graphics system Wayland
Java version:
openjdk version "" 2023-08-24
OpenJDK Runtime Environment (build
OpenJDK 64-Bit Server VM (build, mixed mode, sharing)
STM32CubeMX version 6.9.1
STM32CubeIDE version 1.13.1
STM32CubeProgrammer API v2.14.0 | Linux-64Bits
STM32 Trusted Package Creator v2.14.0 STMicroelectronics
Thanks for any suggestion.

Hope this works for you ☺️

I always installed with sudo. The directory is by default: "home/STM32Cube/repository/"

You can change the default repository when opening your CubeIDE.

Associate III

Realese 1.12.1 works fine, 1.13.1 still doesn't work.
Can multiple releases coexist on the same computer?

Yes, you can have multiple release in the same computer

Best regards.


Thank you very much. 

Now I have 1.10.1 and 1.12.1, they work fine. 1.13.1 does't work :face_with_steam_from_nose:

If you want I can post the logs of 1.13.1

Lead II

Ok thanks.

Best regards


I will continue my work with release 1.12.1 while waiting for the solution to the problem of release 1.13.1.
Thanks for your help.

> If your question is answered please check this answer as best answer to be diffused.

> If that works fine. Close this topic by marking this answer as best answer.

> If your question is answered please check the answer as best answer to be diffused.

Seriously? It seems that begging three times is not enough - try writing it in every post at the beginning and the end!

And the answers are not "diffused". Probably you mean "spread" or something like that. Actually the word "diffusion" is a pretty international word and is the same in almost all languages. It's somewhat strange to not know it's meaning...

Hello @Piranha 

I'm a new community member. Thanks for your feedback and I will try to correct .

Best regards.