STM32CubeIDE (MPUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

STM32CubeIDE 1.16.0 released

STM32CubeIDE 1.16.0 was released today on st.com as well as an in-tool update patch. What is new in 1.16.0?Microcontroller and board lists aligned with STM32CubeMX v6.12.0 : STM32C0 ,STM32WB0 and STM32MP25XXAdded CMake support for multicontext projec...

Resolved! No source available for "g_pfnVectors() at 0x0"

Hello,I'm trying to debug a firmware in production mode using STM32cudeIDE, but when debugger starts it seems g_pfnVectors isn't properly created. When I stops debugger and view the dissambled code I found that it always points on the first line:0000...

MBassi by Associate III
  • 1549 Views
  • 6 replies
  • 0 kudos

STM32CubeIDE 1.13.0 released

STM32CubeIDE 1.13.0 was released today on st.com as well as an in-tool update patch. What is new in 1.13.0? Added the support for new microcontrollers in the STM32U5 seriesAdded the support for new microcontrollers in the STM32WBA seriesAdded the sup...

Resolved! GTK apps missing libraries

Hi.I started to play with STM32MP1 micros and have a problem. How can I add so libraries not having "normal" linux tools? I wrote a simple GTK app and I am missing libpcreposix.so.0 

pj_stm by Associate III
  • 1319 Views
  • 2 replies
  • 0 kudos

Modify debug load mode of stm32mp157f-dk2

I am using stm32mp157f-dk2 and followed https://wiki.st.com/stm32mpu/wiki/Getting_started with help of stmcubeIDE. I am able to debug M4 core and also see SWV prints with ST A7 image and M4 image. Both images are available through above ST web site. ...

_legacyfs_online_stmicro_images_0693W00000bjxDbQAI.png _legacyfs_online_stmicro_images_0693W00000bjxC9QAI.png _legacyfs_online_stmicro_images_0693W00000bjxCsQAI.png _legacyfs_online_stmicro_images_0693W00000bjxEFQAY.png
Kalpesh1 by Associate II
  • 559 Views
  • 4 replies
  • 0 kudos

Debugger misses start of the program in STM32CubeIDE

When debugging my firmware using STM32CubeIDE, the debugger seems to miss the start of the program. As an example, when I put breakpoints right at the top of main(), they are ignored. It's not only a couple of lines that are affected, but pretty much...

RPape.1 by Associate II
  • 1377 Views
  • 5 replies
  • 0 kudos

Resolved! stop after Run or Debug action

hello.Now I am using stm32mp157a-ev1 board and coding M4 program on stm32cubeide.However, there is a problem that the stm32cubeide stops at 70% after starting to run or debug.And can check the log for errors in metadata.2023-04-04 17:11:23,560 [INFO]...

0693W00000bhTiGQAU.png
KNam.2 by Associate II
  • 660 Views
  • 4 replies
  • 0 kudos