cancel
Showing results for 
Search instead for 
Did you mean: 

STM32L476 Nucleo - Cube IDE 1.12.0 - LL_PWR_IsActiveFlag_VOS endless loop

EGi
Associate III

Cube IDE 1.12.0 Build 14980_2023_03_01_1550

OS: Windows 11 Pro 22H2 Build 22621.1413

Project using STM32L476 Nucleo board; low level only (no HAL used at all)

I've build my project IOC file using the previous version of Cube. When I open it, I have 3 options: continue / migrate /..

If I select "migrate" and generate code, the following statement appears in my systemclock init

while (LL_PWR_IsActiveFlag_VOS() == 0) { }

According to the source, this waits for the 10th bit in PWR_CR2 to become '1':

#define PWR_SR2_VOSF_Pos            (10U)

This bit seems to be reserved for STM32L471; so why is cube generating this in my project? Fact is: the code waits forever on the above while statement.

0693W00000bhKcTQAU.pngThe best option I found so far is not to migrate my IOC file (unfortunately I did not find a way to attach it).

Differences in comparing the IOC files before and after the migration are only version info:

0693W00000bhKcsQAE.pngKeeping the IOC in the old version prevents generating the endless wait statement.

2 REPLIES 2
Semer CHERNI
ST Employee

Hello @EGi​ 

First let me thank you for posting.

The issue is reproduced and it has been reported to STM32CubeMX development team .

Internal tickets number: 147617 and 147621 (This is an internal tracking number and is not accessible or usable by customers).

BR,

Semer.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Kamil Duljas
Senior III

Don't worry. On this piece of code is open few issues month ago 🙂

​https://github.com/STMicroelectronics/STM32CubeF7/issues/85

https://github.com/STMicroelectronics/STM32CubeL0/issues/31

Dudo