Showing results for 
Search instead for 
Did you mean: 

CubeMX: Project generation have problem

Associate II

MCU reference : STM32F429ZITx

FW package name : STM32Cube FW_F4 V1.25.0

MDK ARM(Keil) version : 5.30

STM32CubeMX verision : 5.6.1

at that time, i want to create code but i can not.

just [the code is successfully generated under ~~ .but MDK ARM V4 project generation have a problem]

how can i solve this problem?

​i can see other qeustion that may already have my problem.

but i cant sole...

ps. i try MDK ARM V4, V5, V5.27.. BUT ALL FAILED​

Associate II

I had the same problem! I uninstalled and re-installed Java and bingo. solved!


I got the same problem. I tried different options and nothing helped. In the end I found in windows registry through regedit history Keil recently opened projects and delete this record. After that, the generation worked fine.

Also in C:\Users\%USER_NAME%\.stm32cubemx\STM32CubeMX.log I found the following entry:

Caused by: D:\_Projects\_Electro\MyProject\MDK-ARM\MyProject.uvoptx (Can not find the file)

In general, this happened to me due to the fact that I deleted all the project files to generate a clean project with pre-existing settings. It seems to me that it shouldn't be so...

Thomas LB
Associate III


I just encountered same issue.

path to the .ioc contained "[" character (folder name was "[DEBUG]_test_adc") and that is what was causing the error... renaming folder to "test_adc", no more error.

Sad bug !

Associate III

Hello friends, problem fixed installation new version CubeMX V6.3.0 for Windows 10. That solved my problem with generating code for Keil.

If you want to open an older project on a newer version of CubeMx, it will have the same problem. so I recommend that for older versions of the project done in CubeMX use v5.2.0.

Also, try some more solutions like reinstalling the Java version older than 11 or short the path to the storage location in CubeMX folder.

Also, pay attention to the Firmware version of the location (Use Default Firmware Location) as some older ones may be incompatible with newer Firmware versions, which can later cause a programming and runing code problem.

By from A.R. 🙂


I had the same problem, I've already uninstall the MXCube, MDK-ARM and Java but still the same. Do anyone have any idea on how to solve the issue? Will gladly appreciate the help!

Thomas LB
Associate III

Hello, did you check you project path ? It needs to be not too long and not contain any special character like "]".