cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

The STM32CubeIDE1.12.1 can't build the B-L475E-IOT01A AWS demo.

lzhij.2
Associate II

When I build the D:\Desktop\stm32Cube\en.x-cube-aws-v1-4-2\STM32CubeExpansion_Cloud_AWS_V1.4.2\Projects\B-L475E-IOT01A , it show me the error:

d:\app\stm32cube\stm32cubeide_1.12.1\stm32cubeide\plugins\com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32.10.3-2021.10.win32_1.0.200.202301161003\tools\arm-none-eabi\bin\ld.exe: cannot use executable file '../../../../../BootLoader_OSC/2_Images_SBSFU/SW4STM32/B-L475E-IOT01_2_Images_SBSFU/Debug\se_interface_app.o' as input to a link.

Though I add the .o into to PATH, it still error. How to deal with it?
_legacyfs_online_stmicro_images_0693W00000bkAA6QAM.pngAnd the demo package is download from st.


_legacyfs_online_stmicro_images_0693W00000bkABYQA2.png

1 ACCEPTED SOLUTION

Accepted Solutions
lzhij.2
Associate II

hello, @KDJEM.1​ 

I found the solution to solved it, click the Window->preferences->STM32Cube->Toolchain Manager. My default toolchain is 10.3-2021.10, it build the project will make error, so, I install the 7-2018 or 9-2020. And set it as default, it can solved the issue, but I show a new error when compile the following:


_legacyfs_online_stmicro_images_0693W00000bkNfbQAE.pngAre there ways to solve it ?

View solution in original post

8 REPLIES 8
KDJEM.1
ST Employee

Hello @lzhij.2​ ,

  

The BootLoader_OSC examples in X-Cube-AWS V1.4.2 package developed with IAR, SW4STM32, Keil, but not for STM32CubeIDE.

For using STM32CubeIDE, you can follow this User manual UM2579 Migration guide from System Workbench to STM32CubeIDE.

I hope this help you!

When your question is answered, please close this topic by choosing Select as Best. This will help other users find that answer faster.

Kaouthar

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

lzhij.2
Associate II

hi, @KDJEM.1​ β€‹

I have tried this, but it still show the same error. And here is some requires in " B-L475E-IOT01_AWS_converter.log ":


_legacyfs_online_stmicro_images_0693W00000bkKqWQAU.pngdoes it matter ?

lzhij.2
Associate II

@KDJEM.1​ 

here is the full error:

"d:\app\stm32cube\stm32cubeide_1.12.1\stm32cubeide\plugins\com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32.10.3-2021.10.win32_1.0.200.202301161003\tools\arm-none-eabi\bin\ld.exe: cannot use executable file '../../../../../BootLoader_OSC/2_Images_SBSFU/SW4STM32/B-L475E-IOT01_2_Images_SBSFU/Debug\se_interface_app.o' as input to a link"

It's the same as it was.

KDJEM.1
ST Employee

Hi @lzhij.2​ ,

I made some tests using STM32CubeIDE.1.12.1 version and I didn't find any issue.

Do you have reproduced it following strictly the compilation order indicated in the readme?

Could you please compile projects in the following order. This is mandatory as each project requests some objects generated by the compilation of the previous one:

 - 2_Images_SECoreBin

 - 2_Images_SBSFU

May this discussion help you!

Please let me know if the issue is solved πŸ™‚ .

Kaouthar

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

lzhij.2
Associate II

@KDJEM.1​ 

I did it as the readme requires, but it still did't work:loudly_crying_face: . What is your Current toolchain ? I want to change it. And I found the same error in the internet but in other product. They said it is because the SBSFU package, I don't know whether it is true.:sad_but_relieved_face:

lzhij.2
Associate II

hello, @KDJEM.1​ 

I found the solution to solved it, click the Window->preferences->STM32Cube->Toolchain Manager. My default toolchain is 10.3-2021.10, it build the project will make error, so, I install the 7-2018 or 9-2020. And set it as default, it can solved the issue, but I show a new error when compile the following:


_legacyfs_online_stmicro_images_0693W00000bkNfbQAE.pngAre there ways to solve it ?

lzhij.2
Associate II

hello, @KDJEM.1​ 

I totaly sovled all issue, about the STM32_Programmer_CLT, I just need to install an app(Programm software) from st into the path as postbuild.sh it writes(just as default path when it is installing). Then it will build successfully. Thanks a lot for your responses😊

KDJEM.1
ST Employee

Hi @lzhij.2​ ,

Glad to know that the issue is already fixed.

Thank you for your sharing the solution πŸ™‚ .

Kaouthar

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.