Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE 1.15.1 released

ST Employee

STM32CubeIDE 1.15.1 was released on as well as an in-tool update patch aligned with STM32CubeMX v6.11.1 that is available for download.

Main issues fixed in this patch:

  • Ticket 177978 : Fixed an issue with ST-LINK firmware upgrade concerning the boards with DFU v2 or older in the version 3.14.5 of ST-LINK GDB server.
  • Ticket 178127 : Fixed an issue with the build settings: The build settings do not save the latest linker modified by the user and select the default linker instead.

Check the errata under this link for more details.

Where do I obtain STM32CubeIDE 1.15.1?

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Bob S

@Semer CHERNIthe link to the release notes returns the 1.15.0 release notes even though the file name has 1151 (i.e. 1.15.1) in it.


I tried to install on Ubuntu 24.04 but I've got an error message:

The following information may help to resolve the situation:

The following packages have unmet dependencies:
st-stm32cubeide-1.15.1 : Depends: libncurses5 but it is not installable
Depends: libpython2.7 but it is not installable
Depends: libwebkit2gtk-4.0-37 but it is not installable
E: Unable to correct problems, you have held broken packages.

Do you have some info about dependencies availability or how to solve this issue?



The STM32CubeIDE-Lnx STM32CubeIDE Generic Linux Installer is working perfectly on Ubuntu 24.04

Senior III

Ubuntu 23.10

openjdk version "1.8.0_402"
OpenJDK Runtime Environment (build 1.8.0_402-8u402-ga-2ubuntu1~23.10.1-b06)
OpenJDK 64-Bit Server VM (build 25.402-b06, mixed mode)

Not able to start IDE version 1.15.1





After choosing wait the same message keeps coming back.

Linux console shows:

Invalid condition id : UX_CORESTACK_Condition cause : null

No problems dlike that when using CubeIDE 1.10

Totally stuck now and cannot continue working on projects....



(Finally able to edit this, ST community website is extremely slow)

1. Remove the .metadata folder in the workspace

2. Start CubeIDE.  (all projects are gone, don't panic...)

3. Select Import project from filesystem (this may crash a few times, during loading some "C" stuff"). ad complianing about some dependencies missing,, just keep trying...

4. Finally it works.

Why,  why need to download IDE from the site and go through all this trouble instead of IDE updating itself via the IDE?








Senior II

I wonder whether ST fixed the major issues in 1.15.0.

I froze my projects on 1.14.1 because this continual upgrading is pointless. Also GCC 12 (which 1.15.0 installs) breaks a few things.

As to why download the installer... it is handy to have the installer executable for the tools used in your actual project. If you update Cube online (which does work) that is convenient but you can never re-create your project environment later. Also you never know whether some muck was left behind which makes things magically work.


Is it possible to allow HRTIM1 on STM32G4 within cube configuration tool to accept lower frequencies (below 100MHz ) if high resolution feature is not being used? I require timer with plenty external set/reset sources and HRTIMER with its events and other features is perfect for this however currently I have to manually modify configuration generated by cube to change APB2 prescaler from DIV2 to DIV16 (SYSCLK= 100MHz, HCLK= 100MHz, HRTIM prescaler DIV4) to allow longer period. Chip works perfectly fine (at least we didn't notice any unexpected behaviour), it's just cumbersome to do this modification after every code regeneration (I just modify 1 param within initialization, instead of overwriting it with my own).