cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to Program My STM32G0B1

Sakthi_Murugesan
Associate II

Sakthi_Murugesan_0-1712739637083.pngSakthi_Murugesan_1-1712739674040.png

I tested PCB with BOOT_0 is Pulldown to gnd & not Pulldown to gnd & tested with both Stlink-V2 & J-Link Segger 

Sakthi_Murugesan_2-1712741525235.png

Even In Cube Programmer also it was not detected.
The MCU In this Board is STM32G0B1CET6 & it was bought in element14, this is the first time I try to program the MCU. 
I tried this for 5 PCBs all are having the same issues.

7 REPLIES 7
SofLit
ST Employee

Which board?

How you did connect st link? On board st link? External stlink? Stlink driver well installed?

Did you update the stlink firmware?

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.
Sakthi_Murugesan
Associate II

The Board which I am put this controller is coustom design which was design.
The st-link is External & I was update to latest version firmware.
The stlink & the jLink Segger is working for my other STM controller, Only this one is notworking.

Suggests the board design is NOT viable. Either connecting to wrong pins or not powered properly. 

Make sure VDDA is connected.

Provide salient portions of schematic. 

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

Insufficient information.

You need to provide the schematics of your custom board so community members could help you efficiently.

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.
Sakthi_Murugesan
Associate II

image.png

 Here is the schematic for refence in The same design I used both STM32G0B1CBT6 & STM32G0B1CET6
The STM32G0B1CBT6 is working But with STM32G0B1CET6 not working I check in STMCUBEMX Both are pin compactable just memory size is different.

Sakthi_Murugesan
Associate II

Did Anyone Face this kind of issue, or anyone have any solution for this?

I don't see something suspecious in your schematics except the nRST pull-up resistor. No need for this resistor as there is one internal on the chip.

You can refer to the reference design provided by AN5096 / Figure 15. STM32G0 Series reference schematic:

SofLit_0-1712941319219.png

 

The STM32G0B1CBT6 is working But with STM32G0B1CET6 not working I check in STMCUBEMX Both are pin compactable just memory size is different.

This statement makes me having a doubt about the chip itself. It could be broken. Is there a possibility to desolder this chip and solder one you know that is working?

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.