Showing results for 
Search instead for 
Did you mean: 

i can't log in myST


This is the first time I use STM32cubeIDE ver 1.15.1 . While using it, there are a few operations that need to be logged in. I already have an account in the practice room at school, but when I log in on my personal laptop, I see a box. "Authentication error manage" dialog as shown belowScreenshot 2024-05-14 171838.png


 meanwhile my internet connection is completely normal.



and here is my device information

Device name DESKTOP-4TDRFA4

Processor 11th Gen Intel(R) Core(TM) i5-1135G7 @ 2.40GHz  2.42 GHz

Installed RAM 8.00 GB (7.74 GB usable)

Device ID 996C43EE-CF99-4860-A14A-D9B1A6AE213A

Product ID 00356-24555-97786-AAOEM

System type 64-bit operating system, x64-based processor

Pen and touch No pen or touch input is available for this display


I don't know how to fix the above situation, I hope someone can assist me as soon as possible

It would be better if you guide me with pictures or videos, my English is not very good, please understand

You can contact me via

sincerely thank !

Associate II

I think a lot of people are having this problem today. Come on ST get it fixed. We are trying to do some work here.


After wasting almost a full day trying to fix the same issue you encountered, I went through the changelogs and saw that ST started forcing the log in in version 1.13.0 so I installed version 1.12.1 and that seems to work fine.

It's annoying having to use an old version, but well... Hope they fix this soon.

Senior III
Associate II

Hi Ole1,

Are you able to log in ?

Then, are you able to upgrade to 1.151.1 ?


Associate II

as said by @Ole1 :

workaround: install CubeIDE 1.12.1

It has no login functionnality and use latest packages.

Ghofrane GSOURI
ST Employee

Hello @dnht 

First let me thank you for posting.

The issue seems to be linked either to the server or the tool network connection settings.

The possibility of having issue with the server is under investigation.

If you are connected to the internet via a proxy, please follow the steps from the article bellow to set the tool correctly.

How to set the network connection parameters for S... - STMicroelectronics Community




ST Employee

Dear all,

Seems the issue has been solved please check from your side.

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.