Showing results for 
Search instead for 
Did you mean: 

STM32F405 Can not connect to target

Associate III

Hello All, I Hope you are well.

I am facing a problem that I spent A LOT of time on. I designed a custom board featuring the STM32F405RGT6 but i cannot connect to it at all.. I will attach the schematic and the board's pictures below. (The schematic is a PDF where I attached the sheet of the MCU's circuitry only there are other sheets for other parts of the board)


Things to mention:
1- I've assembled the board myself (But i checked the connectivity and voltages on the necessary nodes by a multimeter and i tested on the chip's pins not on the PCB pads and got the following:

-VDD on all VDD pins are 3.31V (measured directly on the pins)

-VDDA is also supplied by the same source with around 3.31V (measured directly on the pins)

-Vcap1 and Vcap2 are both 1.26V (measured on the the two Caps of 2u2 value)

-Reset Pin is 3.31V


2- I got suspicious about the SWD pinout that i did so i used an adapter and a Nucleo board's ST-Link to connect to my board where I measured the resistance between the SWD Pins and the Nucleo board and all are connected with reasonable resistance (Under 10 Ohms) (I got so desperate of the cause that I replaced the termination resistors of 49R9 with 0Ohms ones)

3- I got in both modes of Boot0 being Low and High. (Boot1 is floating would that cause the lack of connectivity?)


Am I missing something?!

Any kind of help would be much much appreciate. Thank you in Advance.





Hi, thank for your reply, 

*Regarding the 49R9 terminations I've replaced them with 0 Ohms way earlier and that unfortunately didn't help.. 

*For the frequency I've tried with many frequencies with no Luck

*sorry what do you mean by remove "protection" is there anything I'm doing wrong in the CubeProgrammer settings? This is the first time i use it.. so,,

*I've also disconnected the SWO trace pin and the Nrst pins also with the same result. 


*I will try to inspect the pins on a scope as @AScha.3  suggested.. meanwhile I'm waiting for MCU replacements. What's confusing me is that the chip doesn't seem dead to me. But nevertheless it's refusing to connect for some reason


D302 D303 ...  and +3.3VA isnt in schematics 

But primary mistake is missed pin 63 VSS on you schematics.

Hi again, 

You're right pin 63 is not given in the symbol, However, it is actually connected. I checked the PCB viewer and it's present:

Pin63 to ground.png

 And then i tried to delete the track to check if the RatsNest is connected, and yes it is, maybe the symbol has pin 63 connected internally or something,, I don't know:

Pin 63 to ground ratsnest.png

I then did a continuity test from ground to pin 63 of the IC (Not the Pad) and it shows a good connection with 0.3Ohms.

*Now regarding VDDA, it is in schematics and it's supposed to come from an LDO, however since I can't get the MCU to connect, I've shorted the 3v3A supply on my board with the Digital 3v3 supply (easily shorted since i have then next to each other on male headers.) (I've also teste this voltage with a multimeter on the pin itself and it shows 3.3v) 

*Now regarding the ESD protection diodes, I've tested for shorts (as i suspected maybe one of them is damaged by heat since i soldered and de-soldered them quite a few times), but all looks good with no shorts or any problems

Some ESD have capacitance = short for high freq.

Yes I am aware that they form a low impedance path for higher frequencies and the bigh frequency element in such train of pulses is there from the rising edges and has nothing to do with the fundamental frequency of the clock.

but that wouldn't/ (at least shouldn't) cause a problem, as these parts are labeled as (extremely low capacitance ESD protection Diodes), and I honestly took these from other perfectly working designs. 

Anyways i can take them off and try.. I got no better plan...

Thanks 🙏.

Diid you check - without power - for any short to gnd or vdd or neighbor pin  ?

If you feel a post has answered your question, please click "Accept as Solution".

A summary and lesson for anyone after me:

*If you mess up the swd connections for some reason like i did.. and you try to breakout the connections from the socket: The. Pay attention that some wires might be shorted to GND more likely in the connector as it has the original ground channel shortdd to other channels .. so after i messed up and put the SWCLK in one of the grounds it got shorted to ground whenever i connected the connector to the board... so, even if you test these connection to the MCU (i mean swdio and swclk) also check if they got shorted to other channels by the connector: and here's the connector I've been referring to:



You are the man @AScha.3 .. I already mentioned that I messed up the swd before but i took the wires from the adapter and mapped them and (continuity-tested all the pins that they're connected to their respective pins or no..) but as it turns out, for some reason (the place where i had my SWCLK in the adapter was already shorted to ground (inside the adapter itself cause i think there are multiple ground channels in it) .. so no matter how many times i check for shorts while the connector is disconnected nothing is wrong, but once i connected the connector .. the SWCLK gets shorted to ground and is forced to stay low, I've removed the swd connector and directly soldered VDD, SWCLK and SWDIO .. and ground ofc... and it's finally connected !!


I really appreciate your help and keeping up with me .. if it wasn't for your comment it may have taken me more days to figure this one out. 🙏

>and it's finally connected !!

Good to hear !  🙂


Mistakes are the steps on which the wise person rises.

If you feel a post has answered your question, please click "Accept as Solution".