Showing results for 
Search instead for 
Did you mean: 

My CubeMX UI is messed up.

Associate II

I do apologize if this is in wrong section or something. I just don't have time to spend hours looking for correct place to get support. I need to work, not fiddle with misbehaving software.

The issue I am having is that CubeMX (latest version from the website) is totally messed up in my desktop PC with windows 10. Everything works fine on my windows 7 laptop.

One picture tells more than a thousand words so here are two.


It's totally unusable. Never seen this kind of behavior with any software I am using in my windows 10 desktop.

All help is very much appreciated, and sorry again if this is in wrong section.

ST Employee

Hi @EKokk​ 

Could you please tell me more about your setup

java version

Windows version (32 or 64 bit)

screen size

Resolution already shared in your previous message 1680x1050

Ram Size and how much RAM is free when you got this behavior

Associate II


thank you for your reply.

It's AMD Athlon II x 250, 8GB RAM, Radeon 5770, 256GB SSD, Windows 10 64-bit.

I am at work trip for a week or so and can't access the computer to check the java version or RAM usage.

I mostly work on my laptop, but I am in process to upgrading my old laptop (windows 7) to new one with windows 10 and I was using my desktop computer (windows 10) to test if I can get all of my software tools working in windows 10 environment, so I can minimize possible issues beforehand.

Also IIRC the other display is connected to the motherboard IGP, which is Nvidia chip, so this can have an effect also. I think it's best that I run some deeper test when I get back home, like connecting both of the displays back to the Radeon and updating my java, to see if the issue is solved.

I will report my progress here.

Have a happy Christmas for every one!


Same problem here, 4 years later, lmao.

I7 13700k, RTX 3080 Ti.

Windows 11 Pro, 22H2.

4K resolution, 150% scaling.

32gb ram, ~22gb ram free.

Latest stm32cubemx version.


Associate II

Hello Kudos, I am using a laptop which uses RTX3060 and 2K display and I got same issue as yours.

I figured out a workaround is set the window -> display size to larger, and then UI glitch issue disappeared.

I have the same problem!

Associate II

On windows set environment variable J2D_D3D to false can fix this.

You can use the PowerShell command to do this as

setx J2D_D3D false

It seems like unappropriated graphical acceleration issue on windows platform which provide by DirectX3D.