Showing results for 
Search instead for 
Did you mean: 

MX 5.4.0 Bug: cubemx stuck at copying library files while Generating code

Viraj shah
Associate II

can anyone help me with this problem cubemx is stuck at copying library file while i try to generate code for keil mdk version 5.28 cannot close the window and have to terminate the program using task manager i am using windows 10 system0690X00000ArJc0QAF.png

Mikhail Z
Senior II

Did you try to reinstall MX?

Viraj shah
Associate II

Yes i tried that also previously i was using 5.3 version(the same error persisted there, hence i updated mx to 5.4) deleted that installed 5.4 mx and since it was not working i reinstalled 5.4 but still no luck


I'm having the same problem here (STMCubeMX V5.28), program freezes at "Copying library files". Trying to fix this for last 4 hours. I have also tried uninstalling and reinstalling to no avail. I thought it was a problem with Java RTE, so I uninstalled the older version and reinstalled the latest 64 bit. Also no luck. Anyone able to comment or understands what is causing this? Would greatly appreciate any feedback...

Khouloud ZEMMELI
ST Employee

​Hello @Viraj shah​ , could you please share your ioc file ?



Hi @Khouloud ZEMMELI​  please check the attached .ioc file

​It works fine for me :


oh ok that's interesting ,so can you help me figure out with why this isn't working on my PC?

​Please give me some info about your machine , Win 10 32bit /64bit ? java version?  

Hi @Khouloud ZEMMELI​  extremely sorry for replying so late

so i am working on windows 64 bit and java version is 8