cancel
Showing results for 
Search instead for 
Did you mean: 

G474 problem connecting COMP1 output to HRTIM event4 source

jose luu
Associate III

Hi,

What am I missing ?

The connection to the event source is grayed and non selectable, see screen copies of the configuration below.

G474_MX_config.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

here... 🙂

 

just rename txt to ioc . (ioc upload not allowed here - maybe STM dont know, what this ioc should be ...)

If you feel a post has answered your question, please click "Accept as Solution".

View solution in original post

6 REPLIES 6
AScha.3
Principal III

i tried ...but: deselect external in comp

AScha3_0-1700409843019.png

+ not select ext

AScha3_0-1700410180037.png

 

 

 

-> if event4 not possible, use other event (1 or 2...)

AScha3_1-1700409883386.png

try it.

If you feel a post has answered your question, please click "Accept as Solution".
jose luu
Associate III

G474_MX_config_2.png

I initialized COMP2 and tried to select it: it is still grayed, -> something is preventing the selection.

On your side, it seems that you are starting from an already complex configuration (since PA0=COMP1_OUT was busy), could you try recreating a project from scratch, only selecting the processor G474 and configuring COMPx and HRTIM ?

Also I am using the latest cubeMX: 6.9.2, which version do you have ?

ok... (in ide 1.13.1 ) + cube G4 1.51 (actual download) for G474RET6 :

AScha3_0-1700463309149.png

i just set master timer on, not select any "external" in comp and hrtim event .

+

in your pic -> timer D has red cross -> you set something wrong there, clear this ! (cube shows you message, when mouse over the wrong item there , whats wrong)

If you feel a post has answered your question, please click "Accept as Solution".

Could you attach your .ioc file so I can peruse it ?

here... 🙂

 

just rename txt to ioc . (ioc upload not allowed here - maybe STM dont know, what this ioc should be ...)

If you feel a post has answered your question, please click "Accept as Solution".
jose luu
Associate III

Thanks, resolved: 

G474_MX_config_4.png

 SOLUTION SUMMARY:

 the trick is to  *NOT* select "External event 4" in the upper "EXTERNAL EVENT LINES" topic but *enable* "External event 4" in the lower "External Event Configuration" pane.