Showing results for 
Search instead for 
Did you mean: 

CubeMX 6.9.1 doesn't see CubeF7 1.17.1

Bob S

Saw issue in another thread about CubeIDE 1.13.1 unable to generate code from F7 1.17.1 (

Interestingly, CubeMX v6.9.1 (Windows) won't even acknowledge that CubeF7 1.17.1 exists.  It will show 1.17.0 as installed.  If I then manually install the patch (this PC has no internet access), CubeMX then says 1.17.0 is NOT installed and doesn't even show a place holder for 1.17.1.

CubeMX 6.9.1 downloaded on 29 Aug 2023, zip file 560,642,010 bytes.

Lead II

Hello @Bob S 

I've reproduced your issue using CubeMX 6.9.1 and it seems to be working fine (CubeF7 1.17.1 exist in the embedded software packages manager) 


Best regards .


Hello again @Bob S 

I can confirm that  issue after installing the last update (v1.17.1) it looks like the version that has been installed is the 1.17.0 version. 

Also, when I tried to open an exemple on an STMF7 nucleo, I can't open this project using CubeIDE. 

I hope this issue will be reported and fixed soon by @ST Community  @Imen.D 

Best regards


ST Employee

Hello @Bob S ,

We always deliver patches with internal folder name of last full package release.

Please make sure to install the previous version 1.17.0, then copy the extracted patch folder (v1.17.1) and copy it directly into the full package release folder: STM32Cube_FW_F7_V1.17.0.



When your question is answered, please close this topic by clicking "Accept as Solution".

@Imen.D- I've tried it both ways

(1) copying the 1.17.0 directory to 1.17.1 and installing the patch in the 1.17.1 dir.  CubeMX still sees 1.17.0 but does not display anything for 1.17.1,

(2) installing the patch in the 1.17.0 dir.  CubeMX says 1.17.0 is not installed and (still) has no line for 1.17.1.

I am really curious because my CubeMX never shows that 1.17.1 is even a possibility, unlike @Issamos showed above.  I guess my next test is to uninstall and reinstall CubeMX 6.9.1 (and maybe the 1.17.x libs).  I don't expect that to make a difference, but you never know.  But this will have to wait a few days.

FYI - I have done (1) for the F7 v1.16.1 and 1.16.2 and CubeMX shows both as available, and likewise for F4 v1.26.1 and 1.26.2..

Lead II

Thanks @Imen.D 

I've just discovered that after installing the 1.17.1 and the version that has bin installed was 1.17.0. CubeMX proposed a new patch in the "manage software installation" wher I've found a 42MO patch that I've downloaded and installed and it works fine now. @Bob S I suggest you to download the 1.17.0 version and than download and install the patch proposed as update from CubeMX.

Best regards.