Showing results for 
Search instead for 
Did you mean: 

Loading problem with STM32CubIDE_1.14.0

Associate II


I'm trying to get running with a STM32F446. I'm using a Nucleo 64 board for now. I've installed CubeIDE on a new computer running Windows 10 and I get Make error 2 and the messages that it can't find gcc and g++. It seems to be a problem with paths. Could it be looking for some files from a previous version which do not exist on my new computer? I believe the paths and the missing files did not get installed with 1.14.0. What is the path and where do I get the files and where do I put them?


Perhaps create a new project, ensure it builds correctly, and copy your files over to that new project. The toolchain may have changed between versions.

If you feel a post has answered your question, please click "Accept as Solution".


I have tried that. The problems don't seem to be at the project level, but probably at the system level. The toolchain files seem not to exist. I have tried uninstalling  STM32CubeIDE and reinstalling it with the same result.


Pavel A.
Evangelist III

Same issue?

In the project settings add this pre-build command:  echo "$$PATH". What will it print?

Hi Pavel,

Under Run/Debug Settings, I was unable to edit anything. Is there another thing I can try? I have done at least a hundred TI MSP430 and TMS4C projects (Code Composer is another Elipse based IDE), and I have never run into this sort of problem.


Hi Pavel,

I was able to run the path command from build preprocessor setting and got back ' '.


If no project builds successfully, either the STM32CubeIDE installation is bad, perhaps due to an overzealous virus scanner, or you're doing something very wrong. I would assume the former is more likely, but if you wanted to include some screenshots of a fresh CubeMX generated project trying to be built, with the relevant error messages shown, might be able to spot something.

If you feel a post has answered your question, please click "Accept as Solution".


Is this a company-owned PC? Any "security" software or security policy installed by the IT?