Showing results for 
Search instead for 
Did you mean: 

failed to start GDB server error

Associate III

hello forum,

I am getting following error - see picture

I use blue pill f103c8 - voltages are ok - blue pill is alive I can see the LED blink

original st link v2 LED is red - driver is ok no error in device manager

I connected SWD pins

please advise

thank s

Associate II


I had the "Failed to start GDB server" issue at the second launch of a fresh installation of STM32CUBE IDE 1.4.0

I reinstalled the IDE but it did finish the installation and disappeared... oO'

... Avast ate those files in secret ... -__-


Hope this can help some of you to save time with this issue.

Bonne journée.


Associate III

I connected VCC of st-linkv2 to 3.3V of blue pill and

I could download my code to blue pill

however after download and start button

cubeide gives "debugger connection lost " error and doesnot stop at breakpoints

my version 1.4.2

I tried with different SWD frequencies no solution

please advise - thank you - picture of error below picture

Maybe it is your application that use SWD pins as IOs so debugger loose communication.

Can you try a simple empty project and see if debug is ok.

STlink clock at 140 Khz is a bit slow, try above 1MHz.

​Hello @mehmet.karakaya​ ,

Is your problem solved  ?  Did Laurent's suggestion help you?

Best Regards,


When your question is answered, please close this topic by clicking "Accept as Solution".
Associate III

hello ,

my problem still continue

my code is simple blink LED

I use debug version of compiler - I dont use swd pins

my question : will it help to connect STM32 reset pin to ST- Link reset pin ?

( in youtube videos people didnot connect reset pin )

thank you

It could work without the reset line but you have to choose the "software system reset" and not "connect under reset".

It is preferable to connect the reset line in case of applications using swd pins as io or low power debug mode.



Associate II

I have the same problem, when I load it the connection is lost and it doesn't let me load it again, to load it from the IDE I have to erase the Flash, or directly with the STMProgrammer. Once I erase the memory I put the blink or another program and ok it doesn't happen but I load my code again and it happens again. I have been looking to see if there are any overwritten registers or something but I can't find anything.