cancel
Showing results for 
Search instead for 
Did you mean: 

Class C downlink not working in STM32WL55JC2.

RonNad14
Associate
  1. My STM32WL55JC2 is programmed with the example code for Lora End Node given in the SDK v1.3.0.
  2. Class_A is enabled by default and working properly i.e. receive window of the MCU opens only after the periodic uplink.
  3. When the class is set to Class_C in the LmHandlerConfigure(&LmHandlerParams) function, it still functions like a Class_A device.
  4. I also tried to change the class later in the join request, but that was also unsuccessful.

Any suggestions?

2 REPLIES 2
IIRHO.1
ST Employee

Hello @RonNad14 and welcome to ST Community.

I suggest you to take a look at the application notes AN5481, AN5406 and AN5554. You will find what you need to solve your Class C problem.

Best Regards.

Issam

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Dear @IIRHO.1  and @RonNad14 ,

 

I am facing the same issue as the @RonNad14 . Even though I have changed default LoRa class into 'class C', STM32WL55JC1 still behaves as the 'class A' device.

I tried to change class of the device from the Termite, but didn't have any success.

Has anybody found the solution for this problem?

 

Thank you in advance!