Showing results for 
Search instead for 
Did you mean: 

RTOS issue with STM32L4R9ZI new project

Associate II


I have STM32L4R9 discovery board which uses STM32L4R9AI Ic and i am able to work on this using Touchgfx.

We have our own developed PCB with STM32L4R9ZI IC. I used STMCubeMx software to generate project of STM32L4R9ZI. i saw the settings used in development board project and used same settings to create project. 

But RTOS tasks are not working as expected. When i give same priority for GUITask and TouchTask, then only TouchTask gets called. If I change the GUITask priority to High, then Both tasks get called. But TouchTask is getting called twice and gets stuck in task error.

Could you please help to solve the issue.

Thanks and Regards,


Chief III

Can you shed some more light on what's going wrong? What is the state of semaphores, queues, etc?

Associate II

Hi @Martin KJELDSEN​,

This issue i got on the kernel start itself, where i just created tasks and semaphores.

But this issue got solved now. I rolled back STMCubeMX to 5.5.0 and TouchGFX to 4.13.0. Don't know what mistake i made with new software i tried many times to regenerate to solve the issue and not solved. But with these old version of software just followed the same procedure what i followed with new software and in a single shot everything working fine.

As I see, when we generate project from TouchGFX, it uses STMCubeMX version 5.5.0 to generate ST drivers. Is there any plan to use latest version of STMCubeMX while generating project with TOuchGFX.

Thanks for the support